<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<title>New Culture Abuse video: Goo | Glorious Noise</title>
<script src="/cdn-cgi/apps/head/-pmKPTy5W1fBtD_wfE6irkaa3NM.js"></script><link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://gloriousnoise.com/xmlrpc.php">
<!--[if lt IE 9]>
	<script src="http://gloriousnoise.com/wp-content/themes/twentyfourteen/js/html5.js"></script>
	<![endif]-->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Feed" href="http://gloriousnoise.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Comments Feed" href="http://gloriousnoise.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; New Culture Abuse video: Goo Comments Feed" href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/gloriousnoise.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='css-0-css' href='http://gloriousnoise.com/wp-content/mmr/8d8c270f-1555096215.css' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css' href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='css-1-css' href='http://gloriousnoise.com/wp-content/mmr/500715f6-1555096211.min.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='http://gloriousnoise.com/wp-content/themes/twentyfourteen/css/ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='css-2-css' href='http://gloriousnoise.com/wp-content/mmr/8b7716c7-1555096218.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://gloriousnoise.com/wp-content/mmr/6ae32158-1555096210.js'></script>
<link rel='https://api.w.org/' href='http://gloriousnoise.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://gloriousnoise.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://gloriousnoise.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='“They Got the Steely Dan T-shirts. . . .”' href='http://gloriousnoise.com/2019/they-got-the-steely-dan-t-shirts' />
<link rel='next' title='New Laura Jane Grace video: I Hate Chicago' href='http://gloriousnoise.com/2019/new-laura-jane-grace-video-i-hate-chicago' />
<meta name="generator" content="WordPress 5.1.1" />
<link rel="canonical" href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo" />
<link rel='shortlink' href='https://wp.me/p1BLpg-5du' />
<link rel="alternate" type="application/json+oembed" href="http://gloriousnoise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgloriousnoise.com%2F2019%2Fnew-culture-abuse-video-goo" />
<link rel="alternate" type="text/xml+oembed" href="http://gloriousnoise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgloriousnoise.com%2F2019%2Fnew-culture-abuse-video-goo&#038;format=xml" />
<style>.site {margin: 0 auto;max-width: px;width: 100%;}.site-header{max-width: px;}
		@media screen and (min-width: 1110px) {.archive-header,.comments-area,.image-navigation,.page-header,.page-content,.post-navigation,.site-content .entry-header,
	    .site-content .entry-content,.site-content .entry-summary,.site-content footer.entry-meta{padding-left: 55px;}}</style>
<style>
	    .site-content .entry-header,.site-content .entry-content,.site-content .entry-summary,.site-content .entry-meta,.page-content, 
		.comments-area,.post-navigation,.image-navigation,.page-header,.archive-header
		{max-width: 700px;}
	</style>
<style>.site:before,#secondary{width:0;display:none;}.ie8 .site:before,.ie8 #secondary{width:0px;display:none;}
	    .featured-content{padding-left:0;}.site-content,.site-main .widecolumn{margin-left:0;}.ie8 .site-content,.ie8 .site-main .widecolumn{margin-left:0;}
		@media screen and (min-width: 1008px) {.search-box-wrapper{padding-left:0;}}
		@media screen and (min-width: 1080px) {.search-box-wrapper,.featured-content{padding-left:0;}}
		@media screen and (min-width: 1080px) {.grid-content{padding-left:0;}}
	</style>
<style>.hentry{max-width: 1478px;}
	    img.size-full,img.size-large,.wp-post-image,.post-thumbnail img,.site-content .post-thumbnail img{max-height: 1790px;}
	</style>
<style>
	    .site-content .post-thumbnail{background:none;}.site-content a.post-thumbnail:hover{background-color:transparent;}
		.site-content .post-thumbnail img{width:100%;}
	</style>
<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<style type="text/css" id="twentyfourteen-header-css">
			.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
		</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="New Culture Abuse video: Goo" />
<meta property="og:url" content="http://gloriousnoise.com/2019/new-culture-abuse-video-goo" />
<meta property="og:description" content="Video: Culture Abuse &#8211; &#8220;Goo&#8221; Directed by David Kelling and Barbara Georges. Single out now on Epitaph. Culture Abuse won me over when I saw them on the small stage at Riot Fest in…" />
<meta property="article:published_time" content="2019-05-07T14:29:15+00:00" />
<meta property="article:modified_time" content="2019-05-07T14:29:15+00:00" />
<meta property="og:site_name" content="Glorious Noise" />
<meta property="og:image" content="http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo.jpg" />
<meta property="og:image:width" content="672" />
<meta property="og:image:height" content="372" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@gloriousnoise" />
<meta name="twitter:site" content="@gloriousnoise" />
<meta name="twitter:text:title" content="New Culture Abuse video: Goo" />
<meta name="twitter:image" content="http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://gloriousnoise.com/?custom-css=9f7cfe908d" />
</head>
<body class="post-template-default single single-post postid-20056 single-format-standard group-blog header-image singular">
<div id="page" class="hfeed site">
<header id="masthead" class="site-header" role="banner">
<div class="header-main">
<a href="http://gloriousnoise.com/" rel="home">
<img src="http://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" width="174" height="48" alt="">
</a>
<h1 class="site-title"><a href="http://gloriousnoise.com/" rel="home">Glorious Noise</a></h1>
<div class="search-toggle">
<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
</div>
<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
<button class="menu-toggle">Primary Menu</button>
<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
<div class="menu-glono-menu-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-7292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7292"><a href="/">Home</a></li>
<li id="menu-item-7290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7290"><a href="/bb/">Message Boards</a></li>
<li id="menu-item-7291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7291"><a href="/label/">Record Label</a></li>
<li id="menu-item-7295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7295"><a href="http://gloriousnoise.com/contact">Contact Us</a></li>
</ul></div> </nav>
</div>
<div id="search-container" class="search-box-wrapper hide">
<div class="search-box">
<form role="search" method="get" class="search-form" action="http://gloriousnoise.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</header>
<div id="main" class="site-main">
<div id="primary" class="content-area">
<div id="content" class="site-content" role="main">
<article id="post-20056" class="post-20056 post type-post status-publish format-standard has-post-thumbnail hentry category-shorties tag-culture-abuse tag-epitaph tag-videos">

<div id="jake-image-break"><br /><br /></div>

<div class="post-thumbnail">
<img width="672" height="372" alt="" data-srcset="http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo.jpg 672w, http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo-300x166.jpg 300w, http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo-560x310.jpg 560w" sizes="(max-width: 672px) 100vw, 672px" data-src="http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo.jpg" data-sizes="auto" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="672" height="372" src="http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo.jpg 672w, http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo-300x166.jpg 300w, http://gloriousnoise.com/wp-content/uploads/2019/05/Culture-Abuse-Goo-560x310.jpg 560w" sizes="(max-width: 672px) 100vw, 672px" /></noscript> </div>
<header class="entry-header">
<div class="entry-meta">
<span class="cat-links"><a href="http://gloriousnoise.com/category/shorties" rel="category tag">Shorties</a></span>
</div>
<h1 class="entry-title">New Culture Abuse video: Goo</h1>
<div class="entry-meta">
<span class="entry-date"><a href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo" rel="bookmark"><time class="entry-date" datetime="2019-05-07T10:29:15-04:00">May 7, 2019</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="http://gloriousnoise.com/author/jake-brown" rel="author">Jake Brown</a></span></span> <span class="comments-link"><a href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo#respond">Leave a comment</a></span>
</div>
</header>
<div class="entry-content">
<p>Video: <a href="https://www.youtube.com/watch?v=i6zm0qp8TQU" rel="noopener noreferrer" target="_blank">Culture Abuse &#8211; &#8220;Goo&#8221;</a></p>
<div class="lyte-wrapper" style="width:853px;max-width: 100%;margin:5px;">
<div class="lyMe" id="WYL_i6zm0qp8TQU" itemprop="video" itemscope itemtype="https://schema.org/VideoObject"><meta itemprop="thumbnailUrl" content="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyteThumbs.php?origThumbUrl=https%3A%2F%2Fi.ytimg.com%2Fvi%2Fi6zm0qp8TQU%2Fhqdefault.jpg" /><meta itemprop="embedURL" content="https://www.youtube.com/embed/i6zm0qp8TQU" /><meta itemprop="uploadDate" content="2019-05-01T13:56:35.000Z" /></p>
<div id="lyte_i6zm0qp8TQU" data-src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyteThumbs.php?origThumbUrl=https%3A%2F%2Fi.ytimg.com%2Fvi%2Fi6zm0qp8TQU%2Fhqdefault.jpg" class="pL">
<div class="tC">
<div class="tT" itemprop="name">Culture Abuse &#8211; &quot;Goo&quot;</div>
</div>
<div class="play"></div>
<div class="ctrl">
<div class="Lctrl"></div>
<div class="Rctrl"></div>
</div>
</div>
<p><noscript><a href="http://youtu.be/i6zm0qp8TQU"><img src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyteThumbs.php?origThumbUrl=http%3A%2F%2Fi.ytimg.com%2Fvi%2Fi6zm0qp8TQU%2F0.jpg" alt="" width="853" height="460" /><br />Watch this video on YouTube</a></noscript><meta itemprop="description" content="&quot;Goo&quot; by Culture Abuse Stream and download at https://cultureabuse.ffm.to/goo_ Directed by David Kelling &amp; Barbara Georges Additional footage by Rob Soucy Subscribe: https://www.youtube.com/channel/UCHhawUGf_T7aRH-xIWTYfNQ Official Site: http://cultureabuse-uncensored.com Facebook: https://www.facebook.com/cultureabuse... Twitter: https://twitter.com/cultureabuse Instagram: https://www.instagram.com/cultureabus... Spotify: http://spoti.fi/2s6gUQt YouTube Essentials: http://bit.ly/2LgGeRF Lyrics: WISH I COULD RIDE A BIKE ID RIDE IT HOME TO YOU CUZ LATELY ALL MY INSIDES FEEL LIKE GOO WISH I KNEW ALL THE RIGHT WORDS ID SING EM ALL TO YOU MAYBE IT WOULD HELP WHAT WE’RE GOING THROUGH IF I COULD PICK YOU UP AND DUST YOU OFF ID HOLD YOUR HAND WHEN THINGS GOT ROUGH EVERY STEP GOING LICK FOR LICK IM COMING HOME Credits: GOO was recorded in Los Angeles, CA. at Balboa Recording Studios in Eagle Rock Mastered by Jeff Abarta Performed by Culture Abuse Written by David Kelling Additional drums by Hunter Martinez Keys by Danny Nog #cultureabuse #goo #epitaph"></div>
</div>
<div class="lL" style="max-width:100%;width:853px;margin:5px;"></div>
<p><span class="via">Directed by David Kelling and Barbara Georges. Single <a href="https://cultureabuse.ffm.to/goo_" rel="noopener noreferrer" target="_blank">out now</a> on Epitaph.</span></p>
<p>Culture Abuse won me over when I saw them on the small stage at Riot Fest in 2017. They&#8217;re a punk rock band on Epitaph but their songs have a pop sensibility and frontman David Kelling is charming and hilarious.</p>
<p>This 2018 <a href="https://www.vice.com/en_us/article/bjp7dm/culture-abuse-bay-dream-david-kelling-interview" rel="noopener noreferrer" target="_blank">Noisey interview</a> conveys that charm, especially this bit about his mom: “My whole life she’s been like, ‘You have a beautiful voice. You need to sing!’ And I was like, ‘Mom, you don’t get it, I’m fuckin’ punk!’” </p>
<p>Seems like he&#8217;s been taking his mother&#8217;s advice because this new single is a pretty, acoustic love song with a woozy Mellotron line to keep things a little off-kilter.</p>
<p><em>Wish I could ride a bike<br />
I&#8217;d ride it home to you<br />
Cuz lately all my insides feel like goo</em></p>
<p>Ride on, brother. Can&#8217;t wait to hear what&#8217;s next.</p>
<p><strong>Culture Abuse</strong>: <a href="http://cultureabuse-uncensored.com/" target="_blank" rel="noopener noreferrer">web</a>, <a href="https://twitter.com/cultureabuse" target="_blank" rel="noopener noreferrer">twitter</a>, <a href="https://www.amazon.com/gp/search?ie=UTF8&#038;keywords=Culture Abuse&#038;tag=gloriousnoise-20&#038;index=music&#038;linkCode=ur2&#038;camp=1789&#038;creative=9325" target="_blank" rel="noopener noreferrer">amazon</a>, <a href="/redirect-apple.html?a=Culture Abuse" target="_blank" rel="noopener noreferrer">apple</a>, <a href="https://open.spotify.com/search/artists/Culture Abuse" target="_blank" rel="noopener noreferrer">spotify</a>, <a href="https://en.wikipedia.org/wiki/Special:Search?search=Culture Abuse" target="_blank" rel="noopener noreferrer">wiki</a>.</p>
<script type="text/javascript">
jQuery(document).ready(function($) {
	$.post('http://gloriousnoise.com/wp-admin/admin-ajax.php', {action: 'wpt_view_count', id: '20056'});
});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-20056" class="share-twitter sd-button share-icon no-text" href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-20056" class="share-facebook sd-button share-icon no-text" href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="http://gloriousnoise.com/2019/new-culture-abuse-video-goo?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<footer class="entry-meta"><span class="tag-links"><a href="http://gloriousnoise.com/tag/culture-abuse" rel="tag">Culture Abuse</a><a href="http://gloriousnoise.com/tag/epitaph" rel="tag">Epitaph</a><a href="http://gloriousnoise.com/tag/videos" rel="tag">Videos</a></span></footer></article>
<nav class="navigation post-navigation" role="navigation">
<h1 class="screen-reader-text">Post navigation</h1>
<div class="nav-links">
<a href="http://gloriousnoise.com/2019/they-got-the-steely-dan-t-shirts" rel="prev"><span class="meta-nav">Previous Post</span>“They Got the Steely Dan T-shirts. . . .”</a><a href="http://gloriousnoise.com/2019/new-laura-jane-grace-video-i-hate-chicago" rel="next"><span class="meta-nav">Next Post</span>New Laura Jane Grace video: I Hate Chicago</a> </div>
</nav>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/new-culture-abuse-video-goo#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&#038;postid=20056&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=7.2.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;sig=7c3e8009828d7c90152253fa7ff703da9e16e5a7#parent=http%3A%2F%2Fgloriousnoise.com%2F2019%2Fnew-culture-abuse-video-goo" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div>
<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
<aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="height:20px;"></div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7063325316320791" data-ad-slot="9381376248" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></aside><aside id="r34otd-2" class="widget widget_r34otd"><h1 class="widget-title">On This Day: May 20</h1>
<ul class="widgets-list-layout no-grav">
<li style="margin-bottom: 0;">
<div style="">2002:
<a href="http://gloriousnoise.com/2002/frogponding_with_audiogalaxy" rel="bookmark">Frogponding with Audiogalaxy.</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2002:
<a href="http://gloriousnoise.com/2002/70s_rock_pics" rel="bookmark">70s rock pics</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jeff-sabatini">Jeff Sabatini</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="http://gloriousnoise.com/2003/howard_dean" rel="bookmark">Howard Dean</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="http://gloriousnoise.com/2003/glono_promo_spot" rel="bookmark">MP3: GLONO Promo spot</a>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="http://gloriousnoise.com/2003/the_new_pornographers_electric" rel="bookmark">The New Pornographers - Electric Version</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/tom-mantzouranis">Tom Mantzouranis</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2004:
<a href="http://gloriousnoise.com/2004/wilco_a_dream_can_mean_anythin" rel="bookmark">Wilco: A Dream Can Mean Anything</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2004:
<a href="http://gloriousnoise.com/2004/just_a_fan_breaks_10k_mark" rel="bookmark">Just a Fan Breaks $10K Mark</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2005:
<a href="http://gloriousnoise.com/2005/the_black_metal_dialogues" rel="bookmark">The Black Metal Dialogues</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2005:
<a href="http://gloriousnoise.com/2005/revenge_of_the_blue_yoda_socie" rel="bookmark">Revenge of the Blue Yoda Society</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/scott-chambers">Scott Chambers</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2005:
<a href="http://gloriousnoise.com/2005/chris_tsefalas_im_all_right" rel="bookmark">Chris Tsefalas - I'm All Right?</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/vitas-zebraitis">Vitas Zebraitis</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2007:
<a href="http://gloriousnoise.com/2007/smashing_pumpkins_tarantula" rel="bookmark">Smashing Pumpkins - Tarantula</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2008:
<a href="http://gloriousnoise.com/2008/the_felice_brothers_glorious_n" rel="bookmark">The Felice Brothers: Glorious Noise Video</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/john-boston">John Boston</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2008:
<a href="http://gloriousnoise.com/2008/beck_streaming_new_song_record" rel="bookmark">Beck Streaming New Song Recorded With Danger Mouse</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/derek-phillips">Derek Phillips</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="http://gloriousnoise.com/2009/new_york_dolls_at_the_100_club" rel="bookmark">Photos: New York Dolls at the 100 Club, London</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/david-wala">David Wala</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="http://gloriousnoise.com/2009/kara_dioguardi_worst_song_ever" rel="bookmark">Kara DioGuardi writes worst song EVER</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="http://gloriousnoise.com/2009/green_day_doesnt_need_walmart" rel="bookmark">Sales: Green Day Doesn&#039;t Need Wal-Mart</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="http://gloriousnoise.com/2009/fun_with_forkcast_round_14" rel="bookmark">MP3: Fun with Forkcast, Round 14</a>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:
<a href="http://gloriousnoise.com/2010/whites_stripes_marimba" rel="bookmark">Buy the Whites Stripes Marimba</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:
<a href="http://gloriousnoise.com/2010/a_whole_lotta_links_twitter_ro" rel="bookmark">A Whole Lotta Links: Twitter Roundup #15</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2015:
<a href="http://gloriousnoise.com/2015/new-mountain-goats-wrestling-video-featuring-chavo-guerrero" rel="bookmark">New Mountain Goats wrestling video featuring Chavo Guerrero</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2016:
<a href="http://gloriousnoise.com/2016/the-oral-history-of-walk-this-way" rel="bookmark">The Oral History of Walk This Way</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
</ul>
</aside> <aside id="wpt_widget-2" class="widget widget_wpt"> <div class="wpt_widget_content" id="wpt_widget-2_content" data-widget-number="2">
<ul class="wpt-tabs has-3-tabs">
<li class="tab_title"><a href="#" id="comments-tab">Comments</a></li>
<li class="tab_title"><a href="#" id="recent-tab">Recent</a></li>
<li class="tab_title"><a href="#" id="popular-tab">Popular</a></li>
</ul> 
<div class="clear"></div>
<div class="inside">
<div id="popular-tab-content" class="tab-content">
</div> 
<div id="recent-tab-content" class="tab-content">
</div> 
<div id="comments-tab-content" class="tab-content">
<ul>
</ul>
</div> 
<div class="clear"></div>
</div> 
<div class="clear"></div>
</div>
<script type="text/javascript">
				jQuery(function($) {
					$('#wpt_widget-2_content').data('args', {"allow_pagination":"1","post_num":"10","title_length":"15","comment_num":"5","show_thumb":null,"thumb_size":"small","show_date":"1","show_excerpt":null,"excerpt_length":"15","show_comment_num":null,"show_avatar":null,"show_love":null});
				});
			</script>
</aside> <aside id="twitter_timeline-2" class="widget widget_twitter_timeline"><h1 class="widget-title">Twitter</h1><a class="twitter-timeline" data-width="388" data-height="600" data-theme="light" data-link-color="#A25A1B" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter" href="https://twitter.com/gloriousnoise" href="https://twitter.com/gloriousnoise">My Tweets</a></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><aside id="customhtml" class="widget widget_meta">
<ul>
<li><a href="/contributors/">Contributors</a></li>
<li><a href="https://www.instagram.com/glorious.noise/">Instagram</a></li>
</ul>
</aside>
</div></aside></div>
<div id="secondary">
<h2 class="site-description">Rock and roll can change your life.</h2>
<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info"><marquee>
<a href="https://wordpress.org/">Proudly powered by WordPress</a>
</marquee></div>
</footer>
</div>
<script type="text/javascript">var bU='http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyte/';var mOs=null;style = document.createElement('style');style.type = 'text/css';rules = document.createTextNode(".lyte-wrapper-audio div, .lyte-wrapper div {margin:0px; overflow:hidden;} .lyte,.lyMe{position:relative;padding-bottom:56.25%;height:0;overflow:hidden;background-color:#777;} .fourthree .lyMe, .fourthree .lyte {padding-bottom:75%;} .lidget{margin-bottom:5px;} .lidget .lyte, .widget .lyMe {padding-bottom:0!important;height:100%!important;} .lyte-wrapper-audio .lyte{height:38px!important;overflow:hidden;padding:0!important} .lyMe iframe, .lyte iframe,.lyte .pL{position:absolute !important;top:0;left:0;width:100%;height:100%!important;background:no-repeat scroll center #000;background-size:cover;cursor:pointer} .tC{left:0;position:absolute;top:0;width:100%} .tC{background-image:linear-gradient(to bottom,rgba(0,0,0,0.6),rgba(0,0,0,0))} .tT{color:#FFF;font-family:Roboto,sans-serif;font-size:16px;height:auto;text-align:left;padding:5px 10px 50px 10px} .play{background:no-repeat scroll 0 0 transparent;width:88px;height:63px;position:absolute;left:43%;left:calc(50% - 44px);left:-webkit-calc(50% - 44px);top:38%;top:calc(50% - 31px);top:-webkit-calc(50% - 31px);} .widget .play {top:30%;top:calc(45% - 31px);top:-webkit-calc(45% - 31px);transform:scale(0.6);-webkit-transform:scale(0.6);-ms-transform:scale(0.6);} .lyte:hover .play{background-position:0 -65px;} .lyte-audio .pL{max-height:38px!important} .lyte-audio iframe{height:438px!important} .ctrl{background:repeat scroll 0 -220px rgba(0,0,0,0.3);width:100%;height:40px;bottom:0px;left:0;position:absolute;} .lyte-wrapper .ctrl{display:none}.Lctrl{background:no-repeat scroll 0 -137px transparent;width:158px;height:40px;bottom:0;left:0;position:absolute} .Rctrl{background:no-repeat scroll -42px -179px transparent;width:117px;height:40px;bottom:0;right:0;position:absolute;padding-right:10px;}.lyte-audio .play{display:none}.lyte-audio .ctrl{background-color:rgba(0,0,0,1)}.hidden{display:none}" );if(style.styleSheet) { style.styleSheet.cssText = rules.nodeValue;} else {style.appendChild(rules);}document.getElementsByTagName('head')[0].appendChild(style);</script><script type="text/javascript" async src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyte/lyte-min.js?wyl_version=1.7.7"></script> <div id="sharing_email" style="display: none;">
<form action="/2019/new-culture-abuse-video-goo" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value="" />
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value="" />
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value="" />
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img style="float: right; display: none" class="loading" src="http://gloriousnoise.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input type="submit" value="Send Email" class="sharing_send" />
<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<link rel='stylesheet' id='css-5-css' href='http://gloriousnoise.com/wp-content/mmr/e8460d96-1532980087.min.css' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpt = {"ajax_url":"http:\/\/gloriousnoise.com\/wp-admin\/admin-ajax.php"};var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://gloriousnoise.com/wp-content/mmr/1b7131d1-1555096220.min.js'></script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=20056&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.2.1&show_cookie_consent=10&has_cookie_consent=0&sig=7c3e8009828d7c90152253fa7ff703da9e16e5a7#parent=http%3A%2F%2Fgloriousnoise.com%2F2019%2Fnew-culture-abuse-video-goo" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=20056&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.2.1&show_cookie_consent=10&has_cookie_consent=0&sig=7c3e8009828d7c90152253fa7ff703da9e16e5a7#parent=http%3A%2F%2Fgloriousnoise.com%2F2019%2Fnew-culture-abuse-video-goo";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-201921.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.2.1',blog:'23776706',post:'20056',tz:'-4',srv:'gloriousnoise.com'} ]);
	_stq.push([ 'clickTrackerInit', '23776706', '20056' ]);
</script>
</body>
</html>
