<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<title>New Christian Lee Hutson video: Lose This Number | Glorious Noise</title>
<script src="/cdn-cgi/apps/head/-pmKPTy5W1fBtD_wfE6irkaa3NM.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="http://gloriousnoise.com/xmlrpc.php">
<!--[if lt IE 9]>
	<script src="http://gloriousnoise.com/wp-content/themes/twentyfourteen/js/html5.js"></script>
	<![endif]-->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Feed" href="http://gloriousnoise.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Comments Feed" href="http://gloriousnoise.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; New Christian Lee Hutson video: Lose This Number Comments Feed" href="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number/feed" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/gloriousnoise.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='css-0-css' href='http://gloriousnoise.com/wp-content/mmr/8d8c270f-1581620262.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css' href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='css-1-css' href='http://gloriousnoise.com/wp-content/mmr/500715f6-1581620271.min.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='http://gloriousnoise.com/wp-content/themes/twentyfourteen/css/ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='css-2-css' href='http://gloriousnoise.com/wp-content/mmr/8b7716c7-1581620274.min.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://gloriousnoise.com/wp-content/mmr/6ae32158-1581620274.min.js'></script>
<link rel='https://api.w.org/' href='http://gloriousnoise.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://gloriousnoise.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://gloriousnoise.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='New Amanda Shires video: Deciphering Dreams' href='http://gloriousnoise.com/2020/new-amanda-shires-video-deciphering-dreams' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number" />
<link rel='shortlink' href='https://wp.me/p1BLpg-5uA' />
<link rel="alternate" type="application/json+oembed" href="http://gloriousnoise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgloriousnoise.com%2F2020%2Fnew-christian-lee-hutson-video-lose-this-number" />
<link rel="alternate" type="text/xml+oembed" href="http://gloriousnoise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgloriousnoise.com%2F2020%2Fnew-christian-lee-hutson-video-lose-this-number&#038;format=xml" />
<style>.site {margin: 0 auto;max-width: px;width: 100%;}.site-header{max-width: px;}
		@media screen and (min-width: 1110px) {.archive-header,.comments-area,.image-navigation,.page-header,.page-content,.post-navigation,.site-content .entry-header,
	    .site-content .entry-content,.site-content .entry-summary,.site-content footer.entry-meta{padding-left: 55px;}}</style>
<style>
	    .site-content .entry-header,.site-content .entry-content,.site-content .entry-summary,.site-content .entry-meta,.page-content, 
		.comments-area,.post-navigation,.image-navigation,.page-header,.archive-header
		{max-width: 700px;}
	</style>
<style>.site:before,#secondary{width:0;display:none;}.ie8 .site:before,.ie8 #secondary{width:0px;display:none;}
	    .featured-content{padding-left:0;}.site-content,.site-main .widecolumn{margin-left:0;}.ie8 .site-content,.ie8 .site-main .widecolumn{margin-left:0;}
		@media screen and (min-width: 1008px) {.search-box-wrapper{padding-left:0;}}
		@media screen and (min-width: 1080px) {.search-box-wrapper,.featured-content{padding-left:0;}}
		@media screen and (min-width: 1080px) {.grid-content{padding-left:0;}}
	</style>
<style>.hentry{max-width: 1478px;}
	    img.size-full,img.size-large,.wp-post-image,.post-thumbnail img,.site-content .post-thumbnail img{max-height: 1790px;}
	</style>
<style>
	    .site-content .post-thumbnail{background:none;}.site-content a.post-thumbnail:hover{background-color:transparent;}
		.site-content .post-thumbnail img{width:100%;}
	</style>
<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<style type="text/css" id="twentyfourteen-header-css">
			.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
		</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="New Christian Lee Hutson video: Lose This Number" />
<meta property="og:url" content="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number" />
<meta property="og:description" content="Video: Christian Lee Hutson &#8211; &#8220;Lose This Number&#8221; Directed by Zoe Donahoe and Adam Sputh. From Beginners, due May 29 on Anti. Wow. So Christian Lee Hutson&#8217;s &#8220;Northsider…" />
<meta property="article:published_time" content="2020-02-18T16:10:42+00:00" />
<meta property="article:modified_time" content="2020-02-14T20:14:25+00:00" />
<meta property="og:site_name" content="Glorious Noise" />
<meta property="og:image" content="http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number.jpg" />
<meta property="og:image:width" content="672" />
<meta property="og:image:height" content="372" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@gloriousnoise" />
<meta name="twitter:site" content="@gloriousnoise" />
<meta name="twitter:text:title" content="New Christian Lee Hutson video: Lose This Number" />
<meta name="twitter:image" content="http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://gloriousnoise.com/?custom-css=9a329b15ab" />
</head>
<body class="post-template-default single single-post postid-21116 single-format-standard group-blog header-image singular">
<div id="page" class="hfeed site">
<header id="masthead" class="site-header" role="banner">
<div class="header-main">
<a href="http://gloriousnoise.com/" rel="home">
<img width="174" height="48" alt="" data-src="http://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="http://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" width="174" height="48" alt=""></noscript>
</a>
<h1 class="site-title"><a href="http://gloriousnoise.com/" rel="home">Glorious Noise</a></h1>
<div class="search-toggle">
<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
</div>
<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
<button class="menu-toggle">Primary Menu</button>
<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
<div class="menu-glono-menu-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-7292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7292"><a href="/">Home</a></li>
<li id="menu-item-7290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7290"><a href="/bb/">Message Boards</a></li>
<li id="menu-item-7291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7291"><a href="/label/">Record Label</a></li>
<li id="menu-item-7295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7295"><a href="http://gloriousnoise.com/contact">Contact Us</a></li>
</ul></div> </nav>
</div>
<div id="search-container" class="search-box-wrapper hide">
<div class="search-box">
<form role="search" method="get" class="search-form" action="http://gloriousnoise.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</header>
<div id="main" class="site-main">
<div id="primary" class="content-area">
<div id="content" class="site-content" role="main">
<article id="post-21116" class="post-21116 post type-post status-publish format-standard has-post-thumbnail hentry category-shorties tag-anti tag-christian-lee-hutson tag-videos">

<div id="jake-image-break"><br /><br /></div>

<div class="post-thumbnail">
<img width="672" height="372" alt="" data-srcset="http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number.jpg 672w, http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number-300x166.jpg 300w, http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number-560x310.jpg 560w" sizes="(max-width: 672px) 100vw, 672px" data-src="http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number-672x372.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="672" height="372" src="http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number-672x372.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number.jpg 672w, http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number-300x166.jpg 300w, http://gloriousnoise.com/wp-content/uploads/2020/02/Christian-Lee-Hutson-Lose-This-Number-560x310.jpg 560w" sizes="(max-width: 672px) 100vw, 672px" /></noscript> </div>
<header class="entry-header">
<div class="entry-meta">
<span class="cat-links"><a href="http://gloriousnoise.com/category/shorties" rel="category tag">Shorties</a></span>
</div>
<h1 class="entry-title">New Christian Lee Hutson video: Lose This Number</h1>
<div class="entry-meta">
<span class="entry-date"><a href="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number" rel="bookmark"><time class="entry-date" datetime="2020-02-18T11:10:42-05:00">February 18, 2020</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="http://gloriousnoise.com/author/jake-brown" rel="author">Jake Brown</a></span></span> <span class="comments-link"><a href="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number#respond">Leave a comment</a></span>
</div>
</header>
<div class="entry-content">
<p>Video: <a href="https://www.youtube.com/watch?v=SctvheyAUQk" rel="noopener noreferrer" target="_blank">Christian Lee Hutson -- &#8220;Lose This Number&#8221;</a></p>
<div class="lyte-wrapper" title="Christian Lee Hutson - &amp;quot;Lose This Number&amp;quot;" style="width:853px;max-width: 100%;margin:5px;"><div class="lyMe" id="WYL_SctvheyAUQk" itemprop="video" itemscope itemtype="https://schema.org/VideoObject"><div><meta itemprop="thumbnailUrl" content="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyteThumbs.php?origThumbUrl=https%3A%2F%2Fi.ytimg.com%2Fvi%2FSctvheyAUQk%2Fhqdefault.jpg" /><meta itemprop="embedURL" content="https://www.youtube.com/embed/SctvheyAUQk" /><meta itemprop="uploadDate" content="2020-02-06T14:58:13.000Z" /></div><div id="lyte_SctvheyAUQk" data-src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyteThumbs.php?origThumbUrl=https%3A%2F%2Fi.ytimg.com%2Fvi%2FSctvheyAUQk%2Fhqdefault.jpg" class="pL"><div class="tC"><div class="tT" itemprop="name">Christian Lee Hutson - &quot;Lose This Number&quot;</div></div><div class="play"></div><div class="ctrl"><div class="Lctrl"></div><div class="Rctrl"></div></div></div><noscript><a href="http://youtu.be/SctvheyAUQk"><img  alt="" width="853" height="460" data-src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyteThumbs.php?origThumbUrl=http%3A%2F%2Fi.ytimg.com%2Fvi%2FSctvheyAUQk%2F0.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyteThumbs.php?origThumbUrl=http%3A%2F%2Fi.ytimg.com%2Fvi%2FSctvheyAUQk%2F0.jpg" alt="" width="853" height="460" /></noscript><br />Watch this video on YouTube</a></noscript><meta itemprop="description" content="&quot;Lose This Number&quot; by Christian Lee Hutson from the album &#039;Beginners,&#039; available May 29th Pre-order here: https://clh.ffm.to/beginners Directed by: Zoe Donahoe &amp; Adam Sputh Director of Photography: Guido Frenzel Editor: Adam Sputh Coloring: Zoe Donahoe 1st AC: Scott Buck Gaffer: Teodore Davis PA: Robin Alexander Featuring: Sharon Silva Sophia Dueñas Lukas Frank Special thanks: Gerry Donahoe Mara Donahoe Phoebe Bridgers Emily Stouffer Gill Gayle Jamie Davis Official Site: http://www.christianleehutson.com/ Twitter: https://twitter.com/chrisleehutson Instagram: https://www.instagram.com/christianleehutson/ YouTube: https://christianleehutson.lnk.to/Subscribe #christianleehutson #beginners #antirecords"></div></div><div class="lL" style="max-width:100%;width:853px;margin:5px;"></div></p>
<p><span class="via">Directed by Zoe Donahoe and Adam Sputh. From <em><a href="https://clh.ffm.to/beginners" rel="noopener noreferrer" target="_blank">Beginners</a></em>, due May 29 on Anti.</span></p>
<p>Wow. So Christian Lee Hutson&#8217;s &#8220;Northsiders&#8221; blew my mind when I first heard it last year. It&#8217;s one of those rare songs that feels as if it&#8217;s been written directly for you. Like, dude, were you reading my journals from college?</p>
<p>That single appeared as a one-off, but a year later it looks like he has been picked up by Anti- Records, who will be releasing his debut album in May. <em>Beginners</em> was produced by Phoebe Bridgers.</p>
<p>Unlike &#8220;Northsiders,&#8221; the new single is not specifically about my teenage life, but it&#8217;s still haunting and very real. “I think ‘Lose This Number’ is about someone fixating on the past, wishing they could go back and change things,” <a href="http://www.anti.com/news/christian-lee-hutson-signs-to-anti-announces-new-album-beginners/" rel="noopener noreferrer" target="_blank">says Hutson</a>.</p>
<p><em>Bobby helped me track you down cause<br />
I just saw your name in the paper<br />
You said, &#8220;Of course that reminded you of me<br />
Don&#8217;t you know that&#8217;s how a name works?&#8221;</em></p>
<p>That&#8217;s funny. But it gets more serious immediately.</p>
<p><em>I know you don&#8217;t have to forgive me<br />
Hell, you probably shouldn&#8217;t<br />
I got scared and I took off<br />
I wanted to try but I couldn&#8217;t</em></p>
<p>Hutson&#8217;s gift is the ability to disguise poetic heaviness in conversational lyrics and straightforward, unembellished delivery. I can&#8217;t wait to hear the rest of his album.</p>
<p><strong>Christian Lee Hutson</strong>: <a href="http://www.christianleehutson.com/" target="_blank" rel="noopener noreferrer">web</a>, <a href="https://twitter.com/chrisleehutson" target="_blank" rel="noopener noreferrer">twitter</a>, <a href="https://www.amazon.com/gp/search?ie=UTF8&#038;keywords=Christian%20Lee%20Hutson&#038;tag=gloriousnoise-20&#038;index=music&#038;linkCode=ur2&#038;camp=1789&#038;creative=9325" target="_blank" rel="noopener noreferrer">amazon</a>, <a href="/redirect-apple.html?a=Christian%20Lee%20Hutson" target="_blank" rel="noopener noreferrer">apple</a>, <a href="https://open.spotify.com/search/Christian%20Lee%20Hutson" target="_blank" rel="noopener noreferrer">spotify</a>, <a href="https://en.wikipedia.org/wiki/Special:Search?search=Christian%20Lee%20Hutson" target="_blank" rel="noopener noreferrer">wiki</a>.</p>
<script type="text/javascript">
jQuery(document).ready(function($) {
	$.post('http://gloriousnoise.com/wp-admin/admin-ajax.php', {action: 'wpt_view_count', id: '21116'});
});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-21116" class="share-twitter sd-button share-icon no-text" href="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-21116" class="share-facebook sd-button share-icon no-text" href="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://gloriousnoise.com/2020/new-christian-lee-hutson-video-lose-this-number?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<footer class="entry-meta"><span class="tag-links"><a href="http://gloriousnoise.com/tag/anti" rel="tag">Anti</a><a href="http://gloriousnoise.com/tag/christian-lee-hutson" rel="tag">Christian Lee Hutson</a><a href="http://gloriousnoise.com/tag/videos" rel="tag">Videos</a></span></footer></article>
<nav class="navigation post-navigation" role="navigation">
<h1 class="screen-reader-text">Post navigation</h1>
<div class="nav-links">
<a href="http://gloriousnoise.com/2020/new-amanda-shires-video-deciphering-dreams" rel="prev"><span class="meta-nav">Previous Post</span>New Amanda Shires video: Deciphering Dreams</a> </div>
</nav>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/new-christian-lee-hutson-video-lose-this-number#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" data-src="https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&#038;postid=21116&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=2576fffa0b71bfa0fff9db1b43aa6a5bc76185cd#parent=http%3A%2F%2Fgloriousnoise.com%2F2020%2Fnew-christian-lee-hutson-video-lose-this-number" class="jetpack_remote_comment lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&#038;postid=21116&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=2576fffa0b71bfa0fff9db1b43aa6a5bc76185cd#parent=http%3A%2F%2Fgloriousnoise.com%2F2020%2Fnew-christian-lee-hutson-video-lose-this-number" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></noscript></iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div>
<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="height:20px;"></div></div></aside><aside id="r34otd-2" class="widget widget_r34otd"><h1 class="widget-title">On This Day: </h1>
<ul class="widgets-list-layout no-grav">
<li style="margin-bottom: 0;">
<div style="">2002:
<a href="http://gloriousnoise.com/2002/more_best_of_2001_lists" rel="bookmark">More "Best Of 2001" lists</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="http://gloriousnoise.com/2003/louder_than_love_the_witches_a" rel="bookmark">Louder Than Love: The Witches and EsQuire</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/johnny-loftus">Johnny Loftus</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="http://gloriousnoise.com/2003/play_it_backwards" rel="bookmark">Play It Backwards</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2004:
<a href="http://gloriousnoise.com/2004/live_tracks_from_del_and_the_h" rel="bookmark">Live Tracks From Del and the Hieroglypics Crew</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2004:
<a href="http://gloriousnoise.com/2004/why_americans_dont_care_about" rel="bookmark">Why Americans don't care about the Darkness</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2005:
<a href="http://gloriousnoise.com/2005/robbers_on_high_street_tree_ci" rel="bookmark">Robbers On High Street - Tree City</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/sarah-horne">Sarah Horne</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2008:
<a href="http://gloriousnoise.com/2008/pelican_city_of_echoes" rel="bookmark">Pelican - City Of Echoes</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/todd-totale">Todd Totale</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="http://gloriousnoise.com/2009/m_ward_live_in_portland" rel="bookmark">M. Ward: Live in Portland</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/derek-phillips">Derek Phillips</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="http://gloriousnoise.com/2009/album_streams_robyn_hitchcock" rel="bookmark">MP3: Album Streams: Robyn Hitchcock, Benjy Ferree, more</a>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="http://gloriousnoise.com/2009/album_sales_grammy_bump_editio" rel="bookmark">Album Sales: Grammy Bump Edition</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:
<a href="http://gloriousnoise.com/2010/holly_miranda_the_magicians_pr" rel="bookmark">Holly Miranda - The Magician's Private Library</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/todd-totale">Todd Totale</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:
<a href="http://gloriousnoise.com/2010/get_busy_committee_dont_care_a" rel="bookmark">Get Busy Committee - I Don't Care About You</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2019:
<a href="http://gloriousnoise.com/2019/new-better-oblivion-community-center-video-dylan-thomas" rel="bookmark">New Better Oblivion Community Center video: Dylan Thomas</a>
<span class="via-grey">by <a href="http://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
</ul>
</aside><aside id="twitter_timeline-2" class="widget widget_twitter_timeline"><h1 class="widget-title">Twitter</h1><a class="twitter-timeline" data-width="388" data-height="600" data-theme="light" data-link-color="#A25A1B" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter" href="https://twitter.com/gloriousnoise" href="https://twitter.com/gloriousnoise">My Tweets</a></aside> <aside id="wpt_widget-2" class="widget widget_wpt"> <div class="wpt_widget_content" id="wpt_widget-2_content" data-widget-number="2">
<ul class="wpt-tabs has-3-tabs">
<li class="tab_title"><a href="#" id="comments-tab">Comments</a></li>
<li class="tab_title"><a href="#" id="recent-tab">Recent</a></li>
<li class="tab_title"><a href="#" id="popular-tab">Popular</a></li>
</ul> 
<div class="clear"></div>
<div class="inside">
<div id="popular-tab-content" class="tab-content">
</div> 
<div id="recent-tab-content" class="tab-content">
</div> 
<div id="comments-tab-content" class="tab-content">
<ul>
</ul>
</div> 
<div class="clear"></div>
</div> 
<div class="clear"></div>
</div>
<script type="text/javascript">
				jQuery(function($) {
					$('#wpt_widget-2_content').data('args', {"allow_pagination":"1","post_num":"10","title_length":"15","comment_num":"5","show_thumb":null,"thumb_size":"small","show_date":"1","show_excerpt":null,"excerpt_length":"15","show_comment_num":null,"show_avatar":null,"show_love":null});
				});
			</script>
</aside> <aside id="meta-2" class="widget widget_meta"><h1 class="widget-title">Meta</h1> <ul>
<li><a href="http://gloriousnoise.com/wp-login.php">Log in</a></li>
<li><a href="http://gloriousnoise.com/feed">Entries feed</a></li>
<li><a href="http://gloriousnoise.com/comments/feed">Comments feed</a></li>
<li><a href="https://wordpress.org/">WordPress.org</a></li> </ul>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><aside id="customhtml" class="widget widget_meta">
<ul>
<li><a href="/contributors/">Contributors</a></li>
<li><a href="https://www.instagram.com/glorious.noise/">Instagram</a></li>
</ul>
</aside>
</div></aside></div>
<div id="secondary">
<h2 class="site-description">Rock and roll can change your life.</h2>
<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info"><marquee>
<a href="https://wordpress.org/">Proudly powered by WordPress</a>
</marquee></div>
</footer>
</div>
<script type="text/javascript">var bU='http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyte/';var mOs=null;style = document.createElement('style');style.type = 'text/css';rules = document.createTextNode(".lyte-wrapper-audio div, .lyte-wrapper div {margin:0px; overflow:hidden;} .lyte,.lyMe{position:relative;padding-bottom:56.25%;height:0;overflow:hidden;background-color:#777;} .fourthree .lyMe, .fourthree .lyte {padding-bottom:75%;} .lidget{margin-bottom:5px;} .lidget .lyte, .widget .lyMe {padding-bottom:0!important;height:100%!important;} .lyte-wrapper-audio .lyte{height:38px!important;overflow:hidden;padding:0!important} .lyMe iframe, .lyte iframe,.lyte .pL{position:absolute !important;top:0;left:0;width:100%;height:100%!important;background:no-repeat scroll center #000;background-size:cover;cursor:pointer} .tC{left:0;position:absolute;top:0;width:100%} .tC{background-image:linear-gradient(to bottom,rgba(0,0,0,0.6),rgba(0,0,0,0))} .tT{color:#FFF;font-family:Roboto,sans-serif;font-size:16px;height:auto;text-align:left;padding:5px 10px 50px 10px} .play{background:no-repeat scroll 0 0 transparent;width:88px;height:63px;position:absolute;left:43%;left:calc(50% - 44px);left:-webkit-calc(50% - 44px);top:38%;top:calc(50% - 31px);top:-webkit-calc(50% - 31px);} .widget .play {top:30%;top:calc(45% - 31px);top:-webkit-calc(45% - 31px);transform:scale(0.6);-webkit-transform:scale(0.6);-ms-transform:scale(0.6);} .lyte:hover .play{background-position:0 -65px;} .lyte-audio .pL{max-height:38px!important} .lyte-audio iframe{height:438px!important} .ctrl{background:repeat scroll 0 -220px rgba(0,0,0,0.3);width:100%;height:40px;bottom:0px;left:0;position:absolute;} .lyte-wrapper .ctrl{display:none}.Lctrl{background:no-repeat scroll 0 -137px transparent;width:158px;height:40px;bottom:0;left:0;position:absolute} .Rctrl{background:no-repeat scroll -42px -179px transparent;width:117px;height:40px;bottom:0;right:0;position:absolute;padding-right:10px;}.lyte-audio .play{display:none}.lyte-audio .ctrl{background-color:rgba(0,0,0,1)}.lyte .hidden{display:none}" );if(style.styleSheet) { style.styleSheet.cssText = rules.nodeValue;} else {style.appendChild(rules);}document.getElementsByTagName('head')[0].appendChild(style);</script><script type="text/javascript" async src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyte/lyte-min.js?wyl_version=1.7.11"></script><link rel='stylesheet' id='css-5-css' href='http://gloriousnoise.com/wp-content/mmr/e8460d96-1532980087.min.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpt = {"ajax_url":"http:\/\/gloriousnoise.com\/wp-admin\/admin-ajax.php"};var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://gloriousnoise.com/wp-content/mmr/1b7131d1-1581620273.min.js'></script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=21116&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=2576fffa0b71bfa0fff9db1b43aa6a5bc76185cd#parent=http%3A%2F%2Fgloriousnoise.com%2F2020%2Fnew-christian-lee-hutson-video-lose-this-number" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=21116&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=2576fffa0b71bfa0fff9db1b43aa6a5bc76185cd#parent=http%3A%2F%2Fgloriousnoise.com%2F2020%2Fnew-christian-lee-hutson-video-lose-this-number";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type='text/javascript' src='https://stats.wp.com/e-202008.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2',blog:'23776706',post:'21116',tz:'-5',srv:'gloriousnoise.com'} ]);
	_stq.push([ 'clickTrackerInit', '23776706', '21116' ]);
</script>
</body>
</html>
