<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<title>Rock and Roll Hall of Fame Pales in Comparison | Glorious Noise</title>
<script src="/cdn-cgi/apps/head/-pmKPTy5W1fBtD_wfE6irkaa3NM.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://gloriousnoise.com/xmlrpc.php">
<!--[if lt IE 9]>
	<script src="https://gloriousnoise.com/wp-content/themes/twentyfourteen/js/html5.js?ver=3.7.0"></script>
	<![endif]-->
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Feed" href="https://gloriousnoise.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Comments Feed" href="https://gloriousnoise.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Rock and Roll Hall of Fame Pales in Comparison Comments Feed" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison/feed" />
<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/gloriousnoise.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='r34otd-admin-css-css' href='https://gloriousnoise.com/wp-content/plugins/room-34-presents-on-this-day//r34otd-admin.css?ver=5.8.1' media='all' />
<link rel='stylesheet' id='twentyfourteen-jetpack-css' href='https://c0.wp.com/p/jetpack/10.3/modules/theme-tools/compat/twentyfourteen.css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.8.1/wp-includes/css/dist/block-library/style.min.css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css'>
#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://c0.wp.com/c/5.8.1/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://c0.wp.com/c/5.8.1/wp-includes/js/mediaelement/wp-mediaelement.min.css' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css' href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext&#038;display=fallback' media='all' />
<link rel='stylesheet' id='genericons-css' href='https://c0.wp.com/p/jetpack/10.3/_inc/genericons/genericons/genericons.css' media='all' />
<link rel='stylesheet' id='twentyfourteen-style-css' href='https://gloriousnoise.com/wp-content/themes/twentyfourteen/style.css?ver=20190507' media='all' />
<link rel='stylesheet' id='twentyfourteen-block-style-css' href='https://gloriousnoise.com/wp-content/themes/twentyfourteen/css/blocks.css?ver=20190102' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='https://gloriousnoise.com/wp-content/themes/twentyfourteen/css/ie.css?ver=20140701' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/10.3/_inc/social-logos/social-logos.min.css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/10.3/css/jetpack.css' media='all' />
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script src='https://c0.wp.com/p/jetpack/10.3/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script src='https://c0.wp.com/c/5.8.1/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://gloriousnoise.com/wp-json/" /><link rel="alternate" type="application/json" href="https://gloriousnoise.com/wp-json/wp/v2/posts/24199" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://gloriousnoise.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://gloriousnoise.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.1" />
<link rel="canonical" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison" />
<link rel='shortlink' href='https://gloriousnoise.com/?p=24199' />
<link rel="alternate" type="application/json+oembed" href="https://gloriousnoise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgloriousnoise.com%2F2021%2Frock-and-roll-hall-of-fame-pales-in-comparison" />
<link rel="alternate" type="text/xml+oembed" href="https://gloriousnoise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgloriousnoise.com%2F2021%2Frock-and-roll-hall-of-fame-pales-in-comparison&#038;format=xml" />
<style>.site {margin: 0 auto;max-width: px;width: 100%;}.site-header{max-width: px;}
		@media screen and (min-width: 1110px) {.archive-header,.comments-area,.image-navigation,.page-header,.page-content,.post-navigation,.site-content .entry-header,
	    .site-content .entry-content,.site-content .entry-summary,.site-content footer.entry-meta{padding-left: 55px;}}</style>
<style>
	    .site-content .entry-header,.site-content .entry-content,.site-content .entry-summary,.site-content .entry-meta,.page-content, 
		.comments-area,.post-navigation,.image-navigation,.page-header,.archive-header
		{max-width: 700px;}
	</style>
<style>.site:before,#secondary{width:0;display:none;}.ie8 .site:before,.ie8 #secondary{width:0px;display:none;}
	    .featured-content{padding-left:0;}.site-content,.site-main .widecolumn{margin-left:0;}.ie8 .site-content,.ie8 .site-main .widecolumn{margin-left:0;}
		@media screen and (min-width: 1008px) {.search-box-wrapper{padding-left:0;}}
		@media screen and (min-width: 1080px) {.search-box-wrapper,.featured-content{padding-left:0;}}
		@media screen and (min-width: 1080px) {.grid-content{padding-left:0;}}
	</style>
<style>.hentry{max-width: 1478px;}
	    img.size-full,img.size-large,.wp-post-image,.post-thumbnail img,.site-content .post-thumbnail img{max-height: 1790px;}
	</style>
<style>
	    .site-content .post-thumbnail{background:none;}.site-content a.post-thumbnail:hover{background-color:transparent;}
		.site-content .post-thumbnail img{width:100%;}
	</style>
<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
<style type="text/css" id="twentyfourteen-header-css">
				.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
				</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="Rock and Roll Hall of Fame Pales in Comparison" />
<meta property="og:url" content="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison" />
<meta property="og:description" content="The Rock and Roll Hall of Fame is inducting its latest “class” this evening (of course, not the evening you are reading this, but on the evening of October 30, 2021, or, for those of us who are in …" />
<meta property="article:published_time" content="2021-11-01T15:34:04+00:00" />
<meta property="article:modified_time" content="2021-11-03T17:18:53+00:00" />
<meta property="og:site_name" content="Glorious Noise" />
<meta property="og:image" content="https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981.jpg" />
<meta property="og:image:width" content="672" />
<meta property="og:image:height" content="372" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@gloriousnoise" />
<meta name="twitter:site" content="@gloriousnoise" />
<meta name="twitter:text:title" content="Rock and Roll Hall of Fame Pales in Comparison" />
<meta name="twitter:image" content="https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<style id="wp-custom-css">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</style>
</head>
<body class="post-template-default single single-post postid-24199 single-format-standard wp-embed-responsive group-blog header-image singular">
<div id="page" class="hfeed site">
<header id="masthead" class="site-header" role="banner">
<div class="header-main">
<a href="https://gloriousnoise.com/" rel="home">
<img width="174" height="48" alt="Glorious Noise" data-src="https://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" width="174" height="48" alt="Glorious Noise"></noscript>
</a>
<h1 class="site-title"><a href="https://gloriousnoise.com/" rel="home">Glorious Noise</a></h1>
<div class="search-toggle">
<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
</div>
<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
<button class="menu-toggle">Primary Menu</button>
<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
<div class="menu-glono-menu-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-7292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7292"><a href="/">Home</a></li>
<li id="menu-item-7290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7290"><a href="/bb/">Message Boards</a></li>
<li id="menu-item-7291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7291"><a href="/label/">Record Label</a></li>
<li id="menu-item-7295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7295"><a href="https://gloriousnoise.com/contact">Contact Us</a></li>
</ul></div> </nav>
</div>
<div id="search-container" class="search-box-wrapper hide">
<div class="search-box">
<form role="search" method="get" class="search-form" action="https://gloriousnoise.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</header>
<div id="main" class="site-main">
<div id="primary" class="content-area">
<div id="content" class="site-content" role="main">
<article id="post-24199" class="post-24199 post type-post status-publish format-standard has-post-thumbnail hentry category-shorties tag-features tag-rock-and-roll-hall-of-fame">

<div id="jake-image-break"><br /><br /></div>

<div class="post-thumbnail">
<img width="672" height="372" alt="" data-srcset="https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981.jpg 672w, https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981-300x166.jpg 300w, https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981-560x310.jpg 560w" data-src="https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981-672x372.jpg" data-sizes="(max-width: 672px) 100vw, 672px" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="672" height="372" src="https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981-672x372.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981.jpg 672w, https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981-300x166.jpg 300w, https://gloriousnoise.com/wp-content/uploads/2021/10/The-Go-Gos-CREEM-July-1981-560x310.jpg 560w" sizes="(max-width: 672px) 100vw, 672px" /></noscript> </div>
<header class="entry-header">
<div class="entry-meta">
<span class="cat-links"><a href="https://gloriousnoise.com/category/shorties" rel="category tag">Shorties</a></span>
</div>
<h1 class="entry-title">Rock and Roll Hall of Fame Pales in Comparison</h1>
<div class="entry-meta">
<span class="entry-date"><a href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison" rel="bookmark"><time class="entry-date" datetime="2021-11-01T11:34:04-04:00">November 1, 2021</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="https://gloriousnoise.com/author/stephen-macaulay" rel="author">Stephen Macaulay</a></span></span> <span class="comments-link"><a href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison#respond">Leave a comment</a></span>
</div>
</header>
<div class="entry-content">
<p>The Rock and Roll Hall of Fame is inducting its latest “class” this evening (of course, not the evening you are reading this, but on the evening of October 30, 2021, or, for those of us who are in Detroit, “Devil’s Night”). It always seems as though there are pissing and moaning associated with who gets “in” and who doesn’t that goes to a high level of overall pissiness, which Spell Check wanted me to spell “prissiness,” which is also to the point.</p>
<p>Apparently there is a nominating committee that comes up with a list, with the fundamental qualification that the person or group in question having put out their first recording at least 25 years ago. They draw up a list of the people they want to be considered, then that is distributed to some 600 people who are in “the industry” who vote on the names; there is a “fan” quotient that is part of the mix.</p>
<p>The Rock and Roll Hall of Fame Foundation named its first class in 1986, before there was a physical building in Cleveland, which opened in 1995. The first group of musicians? First do the math and recognize that these had to be performers circa 1960, which makes it pre-Beatles and Stones. So those who were named is probably a more eclectic group than this year’s, and this year, according to the organization, is “the most diverse list of Inductees [sic] in the history of the organization. The first group: Chuck Berry, James Brown, Ray Charles, Sam Cooke, Fats Domino, The Everly Brothers, Alan Freed, John Hammond, Buddy Holly, Robert Johnson, Jerry Lee Lewis, Sam Phillips, Elvis Presley, Little Richard, Jimmie Rodgers, Jimmy Yancey. Although there is a distinct absence of women, it is hard to imagine a group of musicians of that eclecticism.</p>
<p>This year’s: Tina Turner, Carole King, The Go-Go’s, JAY-Z, Foo Fighters, Todd Rundgren, Kraftwerk, Charley Patton, Gil Scott-Heron, Clarence Avant.</p>
<p>Putting aside the charitable aspects of the organization—it has 501(c) (3) non-profit status—it seems strange that rock and roll, which is arguably about tearing down monuments, not building them, has a building designed by I.M. Pei—the man who designed a portion of the Louvre, no less—full of memorabilia and such.</p>
<p>And all of the sturm und drang associated with the who made it and who didn’t seems antithetical to the spirit of rock and roll.</p>
<p>But it has been in place now for 35 years, so let’s consider it stare decisis.</p>
<p>That said, there are other halls of fame that are less famous and really deserve more attention.</p>
<p><span id="more-24199"></span></p>
<p>One of them is 284 miles southwest of Cleveland, in Cincinnati.</p>
<p>It is the <a href="https://classicalwalkoffame.org/">American Classical Music Hall of Fame and Museum</a>. It was founded in 1996, making it younger than Rock, and it had its first inductees in 1998. The mission of this organization is to honor “people who have contributed to American music and music in America,” to quote Samuel Adler, who was the co-chair of the hall’s artistic directorate, and given that it has an artistic directorate, you know that this is a serious outfit. And although it is undoubtedly clear from its name, when Adler says “American music,” he doesn’t mean Elvis.</p>
<p>The first inductees to the American Classical Music Hall of Fame and Museum makes this year’s Rock and Roll group look like Wonder Bread.</p>
<p>To wit: Marian Anderson Samuel Barber, Leonard Bernstein, Elliot Carter, Aaron Copland, Duke Ellington, George Gershwin, Howard Hanson, Charles Ives, Scott Joplin, Serge Koussevitzky, John Knowles Paine, Leontyne Price, Fritz Reiner, Arnold Schoenberg, Gunther Schuller, Roger Sessions, Robert Shaw, Nicolas Slonimsky, John Philip Sousa, Isaac Stern, Leopold Stokowski, Igor Stravinsky, Theodore Thomas, Arturo Toscanini, and the United States Marine Band. (No, I am not making that last one up.)</p>
<p>What’s more, it is interesting who is involved in the selection of the honorees. The ACMHF has a Professional Organization Advisory Council (POAC) that is rather comprehensive, including the American Choral Directors Association; American Federation of Musicians, Cincinnati; American Guild of Organists; American Harp Society; American Music Center, Inc.; ASCAP; American String Teachers Association; Broadcast Music, Inc. Chamber Music America; Chorus America; College Band Directors National Association; College Music Society; Conductors Guild, Inc.; Delta Omicron Music Fraternity; League of American Orchestras; Mu Phi Epsilon; Music Critics Association of North America; Music Educators National Conference; Music Publishers’ Association of the US; Music Teachers National Association; National Association of Composers, USA; National Association of Music Merchants; National Association of Schools of Music; National Federation of Music Clubs; The National School Orchestra Association; Opera America, Inc.; Phi Mu Alpha Sinfonia; National Public Radio; Sigma Alpha Iota Music Fraternity; Society for American Music; UCLA.</p>
<p>That is a group in whom one can have complete confidence.</p>
<p>Rock certainly racks up numbers when it comes to people who attend concerts and festivals. OK. This is a smaller number today than it was back in 2019, but you certainly understand the overall magnitude of people who attend shows and buy the merch and suck down the pricey beverages and wonder why the parking costs so damn much.</p>
<p>Here is a number from 2019 that is certainly eye opening: 16.67-million.</p>
<p>That’s the number of people who attended National Football League games in 2019. It breaks down to an average of 66,479 people per game. Major League Baseball had a bigger gross number (remember: more games are played): 68.48 million, or an average of 28,201 per game.</p>
<p>Clearly the music industry has to look at that with more than a bit of envy.</p>
<p>(And here’s something to think about: one of the biggest musical events of the year takes place. . .at the Super Bowl. Musical performance as subset of football.)</p>
<p>Which takes us to another hall of fame, this one 328 miles west of Cleveland, in Whiting, Indiana. Cleveland is on Lake Erie. Whiting is on Lake Michigan. Automatically score one for Whiting.</p>
<p>Whiting is the home of the <a href="https://mascothalloffame.com/">Mascot Hall of Fame</a>. That’s right: a hall of fame dedicated to North American sports mascots. (While some of these characters have big heads, that is a physical manifestation, unlike the big heads that some people have in the music industry.)</p>
<p>The MHOF was founded by David Raymond, the original Phillie Phanatic, in 2005. It was originally an online-only hall, but the good people of Whiting thought it would be a good idea to have something that could draw people to its municipality, so there was a $14-million tax-increment financing package put together, and by the day after Christmas, 2018, the doors opened.</p>
<p>For a mascot to be considered for induction, it must have performed in U.S. major and minor league sports of baseball (MLB, MiLB), basketball (NBA, WNBA), football (NFL, CFL), hockey (NHL, AHL, ECHL), and soccer (MLS, NWSL, USL, NASL), or college divisions of NCAA Divisions I, II, III, NAIA. It can be an independently performing character (solo artist).</p>
<p>Like the Rock and Roll Hall of Fame’s 25-year rule, to get in the Mascot Hall of Fame, the mascot must have been an active performer for 10 years prior to its election and whomever must “be prepared to show documented proof.”</p>
<p>There is a screening committee that determines who makes the list. The list is then turned over to the Executive Committee.</p>
<p>And that Executive Committee has as much—if not more—cred when it comes to selecting who makes it in than any associated with Cleveland. These are men and women who have skin, fur and feathers in the game.</p>
<p>As in:</p>
<p>•	Jon Absey: Mascotted at &gt;900 NBA games. Mascot of the Year in the NBA 5x<br />
•	Zoltan Berencsi: Senior producer for Harlem Globetrotters. &gt;20 years as a professional mascot for NBA, WNBA, NFL, NHL<br />
•	Chris Bergstrom: Director, Fan &amp; Youth Engagement for Boston Red Sox<br />
•	Robert Boudwin, Created YoUDee (the University of Delaware Fightin’ Blue Hen) and Clutch the Bear (Houston Rockets)<br />
•	Chris Bruce: Performed as the aforementioned YouUDee. Extensive experience in the mascot professional sports environment<br />
•	Tom Burgoyne: was the Phillie Phanatic for over 30 years<br />
•	Brad Collins: started his career in 2001 as Sparty at Michigan State University. Other post-grad characters: JJ Jumper, Sherman and Parker. Performed at UCA Nationals B1G Football games, 2004 Final Four, 2015 and 2015 World Series, and 9 MLB All-Star Games<br />
•	Jon Cudo: Original Timberwolves Crunch (1989-96). Also Sport the Fire Dog for the Portland Fire (1998-2000). Created and performed Moondog for the Cleveland Cavaliers for over 15 years.<br />
•	John Decicco: Started as mascot assistant for Miami Marlin home games in 1999 and became the backup Billy the Marlin in 2000. Became full-time Billy The Marlin in 2002. Spent 19 years with the Marlins.<br />
•	Joe Doyle: Worked for various teams before joining the Chicago Blackhawks in 2008. The Tommy Hawk mascot was inducted into the Mascot Hall of Fame in 2017.<br />
•	Tim Falkner: Joined the St. Louis Cardinals in 1996 as “Freebird’s very close friend” and spent 24 seasons with the team.<br />
•	Joby Giacalone: Mascotting includes Joe Bear for Lenoir-Rhyne College, the original Homer the Dragon for the Charlotte Knights, was Hugo the Hornet for the Charlotte Hornets, and was the original Dinger the Dinosaur for the Colorado Rockies. He created COSMO the Sheepdog in 1997 for charity events.<br />
•	Ray Henderson: Has been a professional NBA mascot for 23 years.<br />
•	Dan Kilday: Was the original Cleveland Indians Slider in 1990 and spent 30 seasons with the team.<br />
•	Wes Lockard: Experience includes performances as Duncan of the New Jersey Nets and Burnie of the Miami Heat.<br />
•	Bromley Lowe: Was a mascot for the Baltimore Orioles for 11 seasons, the Baltimore Ravens for four seasons.<br />
•	Dan Meers: Selected as the #1 college mascot at the 1989 National Collegiate Mascot Championships for his work as the University of Missouri’s Truman Tiger. Has performed as the a mascot for the St. Louis Cardinals and the Kansas City Chiefs.<br />
•	Todd “Parney” Parnell: An executive for the Richmond Flying Squirrels and the Montgomery Biscuits.<br />
•	Doug Raymond: The original Phillie Phanatic and founder of the Mascot Hall of Fame.<br />
•	John Routh: Started as Cocky for the University of South Carolina in 1980, then went on to stints as the Miami Maniac, Sebastian the Ibis, Billy the Marlin, Pat C. Gull, Striker, and Hosty the Super Bear.<br />
•	Jennifer Smith: Established Avant Garb, a mascot design and production studio.<br />
•	Kristen Jacob Smith: Worked for the NCAA for 15 years which has given her “the opportunity and enjoyment of meeting hundreds of characters across the country.”<br />
•	Kenn Solomon: Started his mascot career in 1990 as Rocky for the Denver Nuggets.<br />
•	Al Spajer: Not a background in being a mascot (40+ years in the steel industry). Original executive director of the Mascot Hall of Fame during its construction.<br />
•	Glenn Street: Founding chairman of the Mascot Committee of the Calgary Stampede (1984). Established Street Characters in 1987, which creates and manufacturers mascot costumes.</p>
<p>Sort of puts that ceremony at the Rock and Roll Hall of Fame into perspective.</p>
<script type="text/javascript">
jQuery(document).ready(function($) {
	$.post('https://gloriousnoise.com/wp-admin/admin-ajax.php', {action: 'wpt_view_count', id: '24199'});
});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-24199" class="share-twitter sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-24199" class="share-facebook sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-24199" class="share-linkedin sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-24199" class="share-pinterest sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://gloriousnoise.com/2021/rock-and-roll-hall-of-fame-pales-in-comparison?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<footer class="entry-meta"><span class="tag-links"><a href="https://gloriousnoise.com/tag/features" rel="tag">Features</a><a href="https://gloriousnoise.com/tag/rock-and-roll-hall-of-fame" rel="tag">Rock and Roll Hall of Fame</a></span></footer></article>
<nav class="navigation post-navigation" role="navigation">
<h1 class="screen-reader-text">Post navigation</h1>
<div class="nav-links">
<a href="https://gloriousnoise.com/2021/cloudy-with-a-chance-of-meatballs" rel="prev"><span class="meta-nav">Previous Post</span>Cloudy with a Chance of Meatballs*</a><a href="https://gloriousnoise.com/2021/new-spoon-video-the-hardest-cut" rel="next"><span class="meta-nav">Next Post</span>New Spoon video: The Hardest Cut</a> </div>
</nav>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/rock-and-roll-hall-of-fame-pales-in-comparison#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" data-src="https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&#038;postid=24199&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=0&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=49d44db220d3d22f91bc38837b33056ad0e0ad3a#parent=https%3A%2F%2Fgloriousnoise.com%2F2021%2Frock-and-roll-hall-of-fame-pales-in-comparison" class="jetpack_remote_comment lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div>
<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="height:20px;"></div></div></aside><aside id="r34otd-2" class="widget widget_r34otd"><h1 class="widget-title">On This Day: </h1>
<ul class="widgets-list-layout no-grav">
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="https://gloriousnoise.com/2003/songs_ohia_magnolia_electric_c" rel="bookmark">Songs: Ohia - Magnolia Electric Co</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/nick-latus">Nick Latus</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="https://gloriousnoise.com/2003/interview_with_an_independent" rel="bookmark">Interview with an Independent Tour Manager</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="https://gloriousnoise.com/2003/tell_us_the_truth" rel="bookmark">Tell Us the Truth</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2004:
<a href="https://gloriousnoise.com/2004/benchley_schizopolis_resurgent" rel="bookmark">Benchley: Schizopolis Resurgent</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2005:
<a href="https://gloriousnoise.com/2005/pete_doherty_interview" rel="bookmark">Pete Doherty Interview</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2005:
<a href="https://gloriousnoise.com/2005/beastie_boys_concert_film_awes" rel="bookmark">Beastie Boys Concert Film: Awesome: I Fuckin' Shot That</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2008:
<a href="https://gloriousnoise.com/2008/vote_1" rel="bookmark">Vote!</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2008:
<a href="https://gloriousnoise.com/2008/album_streams_mavis_staples" rel="bookmark">Album Streams: Mavis Staples, Led Zeppelin, more</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="https://gloriousnoise.com/2009/mad_men_the_grown_ups" rel="bookmark">Mad Men - The Grown Ups</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/derek-phillips">Derek Phillips</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="https://gloriousnoise.com/2009/johnny_rotten_lydon_favorite_r" rel="bookmark">Johnny Rotten's Favorite Records</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="https://gloriousnoise.com/2009/beatles_stereo_box_in_limited" rel="bookmark">Beatles Stereo Box in Limited Ed. USB Drives</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/derek-phillips">Derek Phillips</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="https://gloriousnoise.com/2009/sales_michael_jackson_creed_st" rel="bookmark">Sales: Michael Jackson, Creed, Sting, oh my...</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2014:
<a href="https://gloriousnoise.com/2014/new-father-john-misty-album-in-february" rel="bookmark">New Father John Misty Album in February</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2020:
<a href="https://gloriousnoise.com/2020/the-day-after" rel="bookmark">The Day After</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/derek-phillips">Derek Phillips</a></span>
</div>
</li>
</ul>
</aside><aside id="twitter_timeline-3" class="widget widget_twitter_timeline"><h1 class="widget-title">Twitter</h1><a class="twitter-timeline" data-width="600" data-height="400" data-theme="light" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter transparent" href="https://twitter.com/gloriousnoise" href="https://twitter.com/gloriousnoise">My Tweets</a></aside> <aside id="wpt_widget-2" class="widget widget_wpt"> <div class="wpt_widget_content" id="wpt_widget-2_content" data-widget-number="2">
<ul class="wpt-tabs has-3-tabs">
<li class="tab_title"><a href="#" id="comments-tab">Comments</a></li>
<li class="tab_title"><a href="#" id="recent-tab">Recent</a></li>
<li class="tab_title"><a href="#" id="popular-tab">Popular</a></li>
</ul> 
<div class="clear"></div>
<div class="inside">
<div id="popular-tab-content" class="tab-content">
</div> 
<div id="recent-tab-content" class="tab-content">
</div> 
<div id="comments-tab-content" class="tab-content">
<ul>
</ul>
</div> 
<div class="clear"></div>
</div> 
<div class="clear"></div>
</div>
<script type="text/javascript">
				jQuery(function($) {
					$('#wpt_widget-2_content').data('args', {"allow_pagination":"1","post_num":"10","title_length":"15","comment_num":"5","show_thumb":null,"thumb_size":"small","show_date":"1","show_excerpt":null,"excerpt_length":"15","show_comment_num":null,"show_avatar":null,"show_love":null});
				});
			</script>
</aside> <aside id="meta-2" class="widget widget_meta"><h1 class="widget-title">Meta</h1>
<ul>
<li><a href="https://gloriousnoise.com/wp-login.php">Log in</a></li>
<li><a href="https://gloriousnoise.com/feed">Entries feed</a></li>
<li><a href="https://gloriousnoise.com/comments/feed">Comments feed</a></li>
<li><a href="https://wordpress.org/">WordPress.org</a></li>
</ul>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><aside id="customhtml" class="widget widget_meta">
<ul>
<li><a href="/contributors/">Contributors</a></li>
<li><a href="https://www.instagram.com/glorious.noise/">Instagram</a></li>
</ul>
</aside>
</div></aside><aside id="text-6" class="widget widget_text"> <div class="textwidget"><br /></div>
</aside></div>
<div id="secondary">
<h2 class="site-description">Rock and roll can change your life.</h2>
</div>
</div>
 <footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<marquee><a href="https://wordpress.org/" class="imprint">
Proudly powered by WordPress </a></marquee>
</div>
</footer>
</div>
<div id="sharing_email" style="display: none;">
<form action="/2021/rock-and-roll-hall-of-fame-pales-in-comparison" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value="" />
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value="" />
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value="" />
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img style="float: right; display: none" alt="loading" width="16" height="16" data-src="https://gloriousnoise.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" class="loading lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img style="float: right; display: none" class="loading" src="https://gloriousnoise.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" /></noscript>
<input type="submit" value="Send Email" class="sharing_send" />
<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<link rel='stylesheet' id='wpt_widget-css' href='https://gloriousnoise.com/wp-content/plugins/wp-tab-widget/css/wp-tab-widget.css?ver=5.8.1' media='all' />
<script src='https://c0.wp.com/c/5.8.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script src='https://gloriousnoise.com/wp-content/themes/twentyfourteen/js/functions.js?ver=20171218' id='twentyfourteen-script-js'></script>
<script src='https://c0.wp.com/p/jetpack/10.3/_inc/build/twitter-timeline.min.js' id='jetpack-twitter-timeline-js'></script>
<script src='https://gloriousnoise.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.9.2' id='smush-lazy-load-js'></script>
<script src='https://c0.wp.com/c/5.8.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script id='wpt_widget-js-extra'>
var wpt = {"ajax_url":"https:\/\/gloriousnoise.com\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://gloriousnoise.com/wp-content/plugins/wp-tab-widget/js/wp-tab-widget.js?ver=5.8.1' id='wpt_widget-js'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
</script>
<script src='https://c0.wp.com/p/jetpack/10.3/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>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</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=24199&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=49d44db220d3d22f91bc38837b33056ad0e0ad3a#parent=https%3A%2F%2Fgloriousnoise.com%2F2021%2Frock-and-roll-hall-of-fame-pales-in-comparison" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=24199&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=49d44db220d3d22f91bc38837b33056ad0e0ad3a#parent=https%3A%2F%2Fgloriousnoise.com%2F2021%2Frock-and-roll-hall-of-fame-pales-in-comparison";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202144.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.3',blog:'23776706',post:'24199',tz:'-4',srv:'gloriousnoise.com'} ]);
	_stq.push([ 'clickTrackerInit', '23776706', '24199' ]);
</script>
</body>
</html>
