<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<title>Truckin’ | Glorious Noise</title>
<script src="/cdn-cgi/apps/head/-pmKPTy5W1fBtD_wfE6irkaa3NM.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://gloriousnoise.com/xmlrpc.php">
<!--[if lt IE 9]>
	<script src="https://gloriousnoise.com/wp-content/themes/twentyfourteen/js/html5.js?ver=3.7.0"></script>
	<![endif]-->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Feed" href="https://gloriousnoise.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Comments Feed" href="https://gloriousnoise.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Truckin’ Comments Feed" href="https://gloriousnoise.com/2021/truckin-2/feed" />
<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/gloriousnoise.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='r34otd-admin-css-css' href='https://gloriousnoise.com/wp-content/plugins/room-34-presents-on-this-day//r34otd-admin.css?ver=5.6' media='all' />
<link rel='stylesheet' id='twentyfourteen-jetpack-css' href='https://gloriousnoise.com/wp-content/plugins/jetpack/modules/theme-tools/compat/twentyfourteen.css?ver=9.3.1' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://gloriousnoise.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://gloriousnoise.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.6' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css' href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext&#038;display=fallback' media='all' />
<link rel='stylesheet' id='genericons-css' href='https://gloriousnoise.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' media='all' />
<link rel='stylesheet' id='twentyfourteen-style-css' href='https://gloriousnoise.com/wp-content/themes/twentyfourteen/style.css?ver=20190507' media='all' />
<link rel='stylesheet' id='twentyfourteen-block-style-css' href='https://gloriousnoise.com/wp-content/themes/twentyfourteen/css/blocks.css?ver=20190102' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='https://gloriousnoise.com/wp-content/themes/twentyfourteen/css/ie.css?ver=20140701' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css' href='https://gloriousnoise.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.3.1' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://gloriousnoise.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.3.1' media='all' />
<script src='https://gloriousnoise.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script src='https://gloriousnoise.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script src='https://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20201207' id='jetpack_related-posts-js'></script>
<link rel="https://api.w.org/" href="https://gloriousnoise.com/wp-json/" /><link rel="alternate" type="application/json" href="https://gloriousnoise.com/wp-json/wp/v2/posts/22654" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://gloriousnoise.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://gloriousnoise.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.6" />
<link rel="canonical" href="https://gloriousnoise.com/2021/truckin-2" />
<link rel='shortlink' href='https://wp.me/p1BLpg-5To' />
<link rel="alternate" type="application/json+oembed" href="https://gloriousnoise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgloriousnoise.com%2F2021%2Ftruckin-2" />
<link rel="alternate" type="text/xml+oembed" href="https://gloriousnoise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgloriousnoise.com%2F2021%2Ftruckin-2&#038;format=xml" />
<style>.site {margin: 0 auto;max-width: px;width: 100%;}.site-header{max-width: px;}
		@media screen and (min-width: 1110px) {.archive-header,.comments-area,.image-navigation,.page-header,.page-content,.post-navigation,.site-content .entry-header,
	    .site-content .entry-content,.site-content .entry-summary,.site-content footer.entry-meta{padding-left: 55px;}}</style>
<style>
	    .site-content .entry-header,.site-content .entry-content,.site-content .entry-summary,.site-content .entry-meta,.page-content, 
		.comments-area,.post-navigation,.image-navigation,.page-header,.archive-header
		{max-width: 700px;}
	</style>
<style>.site:before,#secondary{width:0;display:none;}.ie8 .site:before,.ie8 #secondary{width:0px;display:none;}
	    .featured-content{padding-left:0;}.site-content,.site-main .widecolumn{margin-left:0;}.ie8 .site-content,.ie8 .site-main .widecolumn{margin-left:0;}
		@media screen and (min-width: 1008px) {.search-box-wrapper{padding-left:0;}}
		@media screen and (min-width: 1080px) {.search-box-wrapper,.featured-content{padding-left:0;}}
		@media screen and (min-width: 1080px) {.grid-content{padding-left:0;}}
	</style>
<style>.hentry{max-width: 1478px;}
	    img.size-full,img.size-large,.wp-post-image,.post-thumbnail img,.site-content .post-thumbnail img{max-height: 1790px;}
	</style>
<style>
	    .site-content .post-thumbnail{background:none;}.site-content a.post-thumbnail:hover{background-color:transparent;}
		.site-content .post-thumbnail img{width:100%;}
	</style>
<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
<style type="text/css" id="twentyfourteen-header-css">
				.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
				</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="Truckin’" />
<meta property="og:url" content="https://gloriousnoise.com/2021/truckin-2" />
<meta property="og:description" content="As there has been a decided tendency on my part to write these things with numbers—many of which have something to do with an alphanumeric that ends with “19,” which I promise not to go into today—…" />
<meta property="article:published_time" content="2021-02-01T15:05:22+00:00" />
<meta property="article:modified_time" content="2021-02-01T18:28:45+00:00" />
<meta property="og:site_name" content="Glorious Noise" />
<meta property="og:image" content="https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck.jpg" />
<meta property="og:image:width" content="672" />
<meta property="og:image:height" content="372" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@gloriousnoise" />
<meta name="twitter:site" content="@gloriousnoise" />
<meta name="twitter:text:title" content="Truckin’" />
<meta name="twitter:image" content="https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://gloriousnoise.com/?custom-css=4e5040ddf9" />
</head>
<body class="post-template-default single single-post postid-22654 single-format-standard wp-embed-responsive group-blog header-image singular">
<div id="page" class="hfeed site">
<header id="masthead" class="site-header" role="banner">
<div class="header-main">
<a href="https://gloriousnoise.com/" rel="home">
<img width="174" height="48" alt="Glorious Noise" data-src="https://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" width="174" height="48" alt="Glorious Noise"></noscript>
</a>
<h1 class="site-title"><a href="https://gloriousnoise.com/" rel="home">Glorious Noise</a></h1>
<div class="search-toggle">
<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
</div>
<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
<button class="menu-toggle">Primary Menu</button>
<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
<div class="menu-glono-menu-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-7292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7292"><a href="/">Home</a></li>
<li id="menu-item-7290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7290"><a href="/bb/">Message Boards</a></li>
<li id="menu-item-7291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7291"><a href="/label/">Record Label</a></li>
<li id="menu-item-7295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7295"><a href="https://gloriousnoise.com/contact">Contact Us</a></li>
</ul></div> </nav>
</div>
<div id="search-container" class="search-box-wrapper hide">
<div class="search-box">
<form role="search" method="get" class="search-form" action="https://gloriousnoise.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</header>
<div id="main" class="site-main">
<div id="primary" class="content-area">
<div id="content" class="site-content" role="main">
<article id="post-22654" class="post-22654 post type-post status-publish format-standard has-post-thumbnail hentry category-shorties tag-cars tag-country">

<div id="jake-image-break"><br /><br /></div>

<div class="post-thumbnail">
<img width="672" height="372" alt="" loading="lazy" data-srcset="https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck.jpg 672w, https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck-300x166.jpg 300w, https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck-560x310.jpg 560w" data-src="https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck-672x372.jpg" data-sizes="(max-width: 672px) 100vw, 672px" class="attachment-post-thumbnail size-post-thumbnail wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="672" height="372" src="https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck-672x372.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck.jpg 672w, https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck-300x166.jpg 300w, https://gloriousnoise.com/wp-content/uploads/2021/02/Carry-Underwood-Truck-560x310.jpg 560w" sizes="(max-width: 672px) 100vw, 672px" /></noscript> </div>
<header class="entry-header">
<div class="entry-meta">
<span class="cat-links"><a href="https://gloriousnoise.com/category/shorties" rel="category tag">Shorties</a></span>
</div>
<h1 class="entry-title">Truckin’</h1>
<div class="entry-meta">
<span class="entry-date"><a href="https://gloriousnoise.com/2021/truckin-2" rel="bookmark"><time class="entry-date" datetime="2021-02-01T10:05:22-05:00">February 1, 2021</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="https://gloriousnoise.com/author/stephen-macaulay" rel="author">Stephen Macaulay</a></span></span> <span class="comments-link"><a href="https://gloriousnoise.com/2021/truckin-2#comments">3 Comments</a></span>
</div>
</header>
<div class="entry-content">
<p>As there has been a decided tendency on my part to write these things with numbers—many of which have something to do with an alphanumeric that ends with “19,” which I promise not to go into today—here are some numbers that, unless you are into the pickup version of trainspotting (the actual British pastime, not the Irvine Welsh book or the Danny Boyle film), you’re probably unaware of.</p>
<p>In 2020 Ford sold 787,422 F-Series trucks. That means that every single person in Seattle could have gotten an F-Series truck last year. The F-Series has been the best-selling pickup for 44 years. That goes back to 1976. The top three songs Billboard Top 100 singles list for that year are (1) “Silly Love Songs” by Wings, (2) “Don’t Go Breaking My Heart” by Elton John and Kiki Dee, (3) “Disco Lady” by Jonnie Taylor. Yes, a long time ago.</p>
<p>There’s more.</p>
<p>Ford hired the Boston Consulting Group late last year to run some numbers on the importance of the F-Series to the U.S. economy. And it turns out that the F-Series supports about 500,000 jobs in the U.S. (this doesn’t mean there are 500,000 people building pickup trucks but that if you take direct employees and dealer employees, there is a multiplier effect leading to that figure). And another multiplier figure: the F-Series contributes about $49-billion to the U.S. Gross Domestic Product.</p>
<p>All of that may seem rather nebulous (unless “Silly Love Songs” is now stuck in your head and you’ve pretty much glazed over the preceding paragraph).</p>
<p>So here’s something that makes it more tangible, perhaps.</p>
<p>The revenue for the iPhone in the U.S. is $55-billion, which explains, in part, why Apple is so valuable. The revenue for the F-Series is $42-billion. The revenue for the NFL, MLB, NBA and NHL combined is $40-billion. (And you might have thought the Super Bowl was a huge deal.) And speaking of sports, all of the Budweiser product sold in the U.S.: $15-billion. (Don’t drive an F-Series, or anything else, for that matter, after consuming some of that.)</p>
<p>And in the context of companies with which we’re all familiar, the F-Series has more revenue than McDonald’s, Nike, Coca-Cola and Starbucks.</p>
<p>A final thing about Ford and pickup trucks: Henry Ford is credited with inventing the pickup, with the first model rolling off the assembly line in 1925. (Among the popular songs in 1925 were “Ah-Ha!” by Ted Lewis and His Jazz Band, “Let’s All Go to Mary’s House” by Savoy Orpheans and “Yes Sir, That’s My Baby” by Ace Brigode &amp; His Fourteen Virginians.)</p>
<p>Yes, there actually is something to do with music in all of this.</p>
<p>It’s the phenomenal popularity of trucks in country music. </p>
<p>For a reason that is absolutely mysterious, a British vehicle insurance site, <a href="https://www.money.co.uk/guides/truck-yeah" rel="noopener" target="_blank">money.co.uk</a>, worked with a U.S. data scientist, John Miller, to analyze country music and trucks. There were more than 16,000 songs analyzed from the past 50 years.</p>
<p>From that base it was determined that 4.16% of all country music has a reference to trucks. The decade of the 2010s had a full 8%.</p>
<p><span id="more-22654"></span></p>
<p>Getting more granular, it was determined that the song that has the most truck references in its lyrics is “The Truck Got Stuck” by Corb Lund, with 6.56% of the lyrics dealing with, presumably, that stuck truck. That is followed by “Chicken Truck” by John Anderson (5.26%), “Truck Driving Man” by George Hamilton IV (3.86%), “If My Truck Could Talk” by Jason Aldean (3.86%), and “Truck Drivin’ Man” by Buck Owens (3.7%).</p>
<p>Looked at from the point of view on a performer’s entire catalog to date, trucks are mentioned in 29.6% of Justin Moore’s songs. That is followed by Craig Campbell at 29.4%, Dean Brody at 27.8%, Canaan Smith at 27.3%, and Easton Corbin at 24.1%.</p>
<p>The only woman to be in the top 20 of having truck references in songs is Miranda Lambert, with 17% of her songs mentioning trucks. Lambert’s “Automatic,” which features a truck, has been streamed on Spotify 41-millioin times. That put her at the number five position in the top 5 truck-related Spotify streams.</p>
<p>Number one, with a commanding lead, is “Before He Cheats” by Carrie Underwood, which is at 208-million. It is followed by “Boys ‘Round Here” by Blake Sheldon (119 million), “John Cougar, John Deere, John 3:16” by Keith Urban (96 million), and “Chattahoochee” by Alan Jackson (72 million).</p>
<p>Back in the 1950s and 1960s, the truck references in songs were to either Dodges or Fords.</p>
<p>But in the 1970s Chevy trucks became the increasingly dominant brand, pulling well ahead of Ford. According to the stats, from the 1950s to the 2020s Ford trucks have been mentioned a combined 2.45% in songs, while Chevy has a cumulative 5.05%.</p>
<p>That said, in 2020, Chevy delivered a total 594,095 Silverados, or about 25% fewer than F-Series.<br />
That said, as you may recall, Bob Seger’s “Like a Rock” was used in Chevy truck commercials from 1991 to 2004.</p>
<p>On August 14, 2002, <em>Advertising Age</em> ran a story with the following headline: “FORD SIGNS &#8216;ANGRY AMERICAN&#8217; SINGER FOR TV ADS.”</p>
<p>Enough said about Toby Keith.</p>
<script type="text/javascript">
jQuery(document).ready(function($) {
	$.post('https://gloriousnoise.com/wp-admin/admin-ajax.php', {action: 'wpt_view_count', id: '22654'});
});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-22654" class="share-twitter sd-button share-icon no-text" href="https://gloriousnoise.com/2021/truckin-2?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-22654" class="share-facebook sd-button share-icon no-text" href="https://gloriousnoise.com/2021/truckin-2?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://gloriousnoise.com/2021/truckin-2?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<footer class="entry-meta"><span class="tag-links"><a href="https://gloriousnoise.com/tag/cars" rel="tag">cars</a><a href="https://gloriousnoise.com/tag/country" rel="tag">country</a></span></footer></article>
<nav class="navigation post-navigation" role="navigation">
<h1 class="screen-reader-text">Post navigation</h1>
<div class="nav-links">
<a href="https://gloriousnoise.com/2021/new-jordi-escape-route" rel="prev"><span class="meta-nav">Previous Post</span>New Jordi: Escape Route</a> </div>
</nav>
<div id="comments" class="comments-area">
<h2 class="comments-title">
3 thoughts on &ldquo;Truckin’&rdquo;	</h2>
<ol class="comment-list">
<li id="comment-633829" class="comment even thread-even depth-1 parent">
<article id="div-comment-633829" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<b class="fn"><a href='https://thehustings.news' rel='external nofollow ugc' class='url'>Todd Lassa</a></b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://gloriousnoise.com/2021/truckin-2#comment-633829"><time datetime="2021-02-01T14:37:56-05:00">February 1, 2021 at 2:37 pm</time></a> </div>
</footer>
<div class="comment-content">
<p>No songs about GMC trucks, right? I&#8217;m just guessing, because I find listening to C&amp;W music as desirable as driving a big pickup truck in city traffic.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://gloriousnoise.com/2021/truckin-2?replytocom=633829#respond' data-commentid="633829" data-postid="22654" data-belowelement="div-comment-633829" data-respondelement="respond" data-replyto="Reply to Todd Lassa" aria-label='Reply to Todd Lassa'>Reply</a></div> </article>
<ol class="children">
<li id="comment-633830" class="comment byuser comment-author-jake-brown odd alt depth-2 parent">
<article id="div-comment-633830" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<b class="fn">Jake Brown</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://gloriousnoise.com/2021/truckin-2#comment-633830"><time datetime="2021-02-01T17:04:05-05:00">February 1, 2021 at 5:04 pm</time></a> </div>
</footer>
<div class="comment-content">
<p>&#8220;He drives a &#8217;57 GMC pickup truck, got a gun rack and a &#8216;Goat Ropers need love too&#8217; sticker.&#8221; Jerry Jeff Walker rules. Yee ha! <a href="https://www.youtube.com/watch?v=L25xkZntMdM" rel="nofollow ugc">https://www.youtube.com/watch?v=L25xkZntMdM</a></p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://gloriousnoise.com/2021/truckin-2?replytocom=633830#respond' data-commentid="633830" data-postid="22654" data-belowelement="div-comment-633830" data-respondelement="respond" data-replyto="Reply to Jake Brown" aria-label='Reply to Jake Brown'>Reply</a></div> </article>
<ol class="children">
<li id="comment-633831" class="comment byuser comment-author-jake-brown even depth-3">
<article id="div-comment-633831" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<b class="fn">Jake Brown</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://gloriousnoise.com/2021/truckin-2#comment-633831"><time datetime="2021-02-01T17:12:18-05:00">February 1, 2021 at 5:12 pm</time></a> </div>
</footer>
<div class="comment-content">
<p>Here&#8217;s an even better version, featuring Willie who forgets how to spell mother. &#8220;He&#8217;s got a ’57 GMC pickup truck with a gun rack and I&#8217;d rather step in shit than smoke its bumper sticker.&#8221; <a href="https://www.youtube.com/watch?v=5_4OgyOg0TQ" rel="nofollow ugc">https://www.youtube.com/watch?v=5_4OgyOg0TQ</a></p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://gloriousnoise.com/2021/truckin-2?replytocom=633831#respond' data-commentid="633831" data-postid="22654" data-belowelement="div-comment-633831" data-respondelement="respond" data-replyto="Reply to Jake Brown" aria-label='Reply to Jake Brown'>Reply</a></div> </article>
</li>
</ol>
</li>
</ol>
</li>
</ol>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/truckin-2#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" data-src="https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&#038;postid=22654&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.3.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=fa986ad3873e143b2e7c7c8d22eb79c7c50c2fdf#parent=https%3A%2F%2Fgloriousnoise.com%2F2021%2Ftruckin-2" class="jetpack_remote_comment lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div>
<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
<aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="height:20px;"></div></div></aside><aside id="r34otd-2" class="widget widget_r34otd"><h1 class="widget-title">On This Day: </h1>
<ul class="widgets-list-layout no-grav">
<li style="margin-bottom: 0;">
<div style="">2003:
<a href="https://gloriousnoise.com/2003/willie_mccool" rel="bookmark">Willie McCool</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>

<li style="margin-bottom: 0;">
<div style="">2004:
<a href="https://gloriousnoise.com/2004/meditations_on_janet_jacksons" rel="bookmark">Meditations on Janet Jackson's Right Breast</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/stephen-macaulay">Stephen Macaulay</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2006:
<a href="https://gloriousnoise.com/2006/hey_hey_my_my_questions_to_con" rel="bookmark">Hey, Hey, My, My: Questions to Consider</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/stephen-macaulay">Stephen Macaulay</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="https://gloriousnoise.com/2009/21_reasons_why_jay_bennett_sho" rel="bookmark">21 Reasons Why Jay Bennett Should Be Back In Wilco</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/derek-phillips">Derek Phillips</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="https://gloriousnoise.com/2009/album_streams_ben_kweller_liza" rel="bookmark">Album Streams: Ben Kweller, Liza Minnelli, more</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2009:
<a href="https://gloriousnoise.com/2009/superbowl_producer_hates_live" rel="bookmark">Superbowl Producer Hates Live Music</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:
<a href="https://gloriousnoise.com/2010/cant_live_without_you_a_farewe" rel="bookmark">Can't Live Without You: A Farewell To The Scorpions</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/todd-totale">Todd Totale</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:
<a href="https://gloriousnoise.com/2010/twitter_roundup_9" rel="bookmark">Twitter Roundup #9</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:
<a href="https://gloriousnoise.com/2010/album_streams_soft_pack_four_t" rel="bookmark">Album Streams: Soft Pack, Four Tet, more</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2011:
<a href="https://gloriousnoise.com/2011/amos_lee_breaks_cake" rel="bookmark">Amos Lee Breaks Cake's Record for Worst-Selling #1</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2011:
<a href="https://gloriousnoise.com/2011/white_stripes_the_last_great_b" rel="bookmark">The White Stripes: The Last Great Band</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/jake-brown">Jake Brown</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2018:
<a href="https://gloriousnoise.com/2018/new-graham-coxon-video-falling" rel="bookmark">New Graham Coxon video: Falling</a>
<span class="via-grey">by <a href="https://gloriousnoise.com/author/derek-phillips">Derek Phillips</a></span>
</div>
</li>
</ul>
</aside><aside id="twitter_timeline-2" class="widget widget_twitter_timeline"><h1 class="widget-title">Twitter</h1><a class="twitter-timeline" data-width="388" data-height="600" data-theme="light" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter" href="https://twitter.com/gloriousnoise" href="https://twitter.com/gloriousnoise">My Tweets</a></aside> <aside id="wpt_widget-2" class="widget widget_wpt"> <div class="wpt_widget_content" id="wpt_widget-2_content" data-widget-number="2">
<ul class="wpt-tabs has-3-tabs">
<li class="tab_title"><a href="#" id="comments-tab">Comments</a></li>
<li class="tab_title"><a href="#" id="recent-tab">Recent</a></li>
<li class="tab_title"><a href="#" id="popular-tab">Popular</a></li>
</ul> 
<div class="clear"></div>
<div class="inside">
<div id="popular-tab-content" class="tab-content">
</div> 
<div id="recent-tab-content" class="tab-content">
</div> 
<div id="comments-tab-content" class="tab-content">
<ul>
</ul>
</div> 
<div class="clear"></div>
</div> 
<div class="clear"></div>
</div>
<script type="text/javascript">
				jQuery(function($) {
					$('#wpt_widget-2_content').data('args', {"allow_pagination":"1","post_num":"10","title_length":"15","comment_num":"5","show_thumb":null,"thumb_size":"small","show_date":"1","show_excerpt":null,"excerpt_length":"15","show_comment_num":null,"show_avatar":null,"show_love":null});
				});
			</script>
</aside> <aside id="meta-2" class="widget widget_meta"><h1 class="widget-title">Meta</h1>
<ul>
<li><a href="https://gloriousnoise.com/wp-login.php">Log in</a></li>
<li><a href="https://gloriousnoise.com/feed">Entries feed</a></li>
<li><a href="https://gloriousnoise.com/comments/feed">Comments feed</a></li>
<li><a href="https://wordpress.org/">WordPress.org</a></li>
</ul>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><aside id="customhtml" class="widget widget_meta">
<ul>
<li><a href="/contributors/">Contributors</a></li>
<li><a href="https://www.instagram.com/glorious.noise/">Instagram</a></li>
</ul>
</aside>
</div></aside></div>
<div id="secondary">
<h2 class="site-description">Rock and roll can change your life.</h2>
<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info">
<marquee><a href="https://wordpress.org/" class="imprint">
Proudly powered by WordPress </a></marquee>
</div>
</footer>
</div>
<link rel='stylesheet' id='wpt_widget-css' href='https://gloriousnoise.com/wp-content/plugins/wp-tab-widget/css/wp-tab-widget.css?ver=5.6' media='all' />
<script src='https://gloriousnoise.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.8.2' id='smush-lazy-load-js'></script>
<script src='https://gloriousnoise.com/wp-includes/js/comment-reply.min.js?ver=5.6' id='comment-reply-js'></script>
<script src='https://gloriousnoise.com/wp-content/themes/twentyfourteen/js/functions.js?ver=20171218' id='twentyfourteen-script-js'></script>
<script src='https://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0' id='jetpack-twitter-timeline-js'></script>
<script src='https://gloriousnoise.com/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>
<script async="async" src='https://gloriousnoise.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.8' id='akismet-form-js'></script>
<script id='wpt_widget-js-extra'>
var wpt = {"ajax_url":"https:\/\/gloriousnoise.com\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://gloriousnoise.com/wp-content/plugins/wp-tab-widget/js/wp-tab-widget.js?ver=5.6' id='wpt_widget-js'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":"1"};
</script>
<script src='https://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.3.1' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=22654&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.3.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=fa986ad3873e143b2e7c7c8d22eb79c7c50c2fdf#parent=https%3A%2F%2Fgloriousnoise.com%2F2021%2Ftruckin-2" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=22654&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.3.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=fa986ad3873e143b2e7c7c8d22eb79c7c50c2fdf#parent=https%3A%2F%2Fgloriousnoise.com%2F2021%2Ftruckin-2";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202105.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.3.1',blog:'23776706',post:'22654',tz:'-5',srv:'gloriousnoise.com'} ]);
	_stq.push([ 'clickTrackerInit', '23776706', '22654' ]);
</script>
</body>
</html>
