<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<title>New Father John Misty video: God&#8217;s Favorite Customer | Glorious Noise</title>
<script src="/cdn-cgi/apps/head/-pmKPTy5W1fBtD_wfE6irkaa3NM.js"></script><link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://gloriousnoise.com/xmlrpc.php">
<!--[if lt IE 9]>
	<script src="http://gloriousnoise.com/wp-content/themes/twentyfourteen/js/html5.js"></script>
	<![endif]-->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Feed" href="http://gloriousnoise.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; Comments Feed" href="http://gloriousnoise.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Glorious Noise &raquo; New Father John Misty video: God&#8217;s Favorite Customer Comments Feed" href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer/feed" />
<script type="3b64d7081993e5362b9477a8-text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/gloriousnoise.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='twentyfourteen-jetpack-css' href='http://gloriousnoise.com/wp-content/plugins/jetpack/modules/theme-tools/compat/twentyfourteen.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css' href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css' href='http://gloriousnoise.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-style-css' href='http://gloriousnoise.com/wp-content/themes/twentyfourteen/style.css?ver=4.9.6' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='http://gloriousnoise.com/wp-content/themes/twentyfourteen/css/ie.css?ver=20131205' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css' href='http://gloriousnoise.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='http://gloriousnoise.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='http://gloriousnoise.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.1.1' type='text/css' media='all' />
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript">
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.1.1'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.1.1'></script>
<link rel='https://api.w.org/' href='http://gloriousnoise.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://gloriousnoise.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://gloriousnoise.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Number One Records: I Like It' href='http://gloriousnoise.com/2018/number-one-records-i-like-it' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer" />
<link rel='shortlink' href='https://wp.me/p1BLpg-4EM' />
<link rel="alternate" type="application/json+oembed" href="http://gloriousnoise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgloriousnoise.com%2F2018%2Fnew-father-john-misty-video-gods-favorite-customer" />
<link rel="alternate" type="text/xml+oembed" href="http://gloriousnoise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fgloriousnoise.com%2F2018%2Fnew-father-john-misty-video-gods-favorite-customer&#038;format=xml" />
<style>.site {margin: 0 auto;max-width: px;width: 100%;}.site-header{max-width: px;}
		@media screen and (min-width: 1110px) {.archive-header,.comments-area,.image-navigation,.page-header,.page-content,.post-navigation,.site-content .entry-header,
	    .site-content .entry-content,.site-content .entry-summary,.site-content footer.entry-meta{padding-left: 55px;}}</style>
<style>
	    .site-content .entry-header,.site-content .entry-content,.site-content .entry-summary,.site-content .entry-meta,.page-content, 
		.comments-area,.post-navigation,.image-navigation,.page-header,.archive-header
		{max-width: 700px;}
	</style>
<style>.site:before,#secondary{width:0;display:none;}.ie8 .site:before,.ie8 #secondary{width:0px;display:none;}
	    .featured-content{padding-left:0;}.site-content,.site-main .widecolumn{margin-left:0;}.ie8 .site-content,.ie8 .site-main .widecolumn{margin-left:0;}
		@media screen and (min-width: 1008px) {.search-box-wrapper{padding-left:0;}}
		@media screen and (min-width: 1080px) {.search-box-wrapper,.featured-content{padding-left:0;}}
		@media screen and (min-width: 1080px) {.grid-content{padding-left:0;}}
	</style>
<style>.hentry{max-width: 1478px;}
	    img.size-full,img.size-large,.wp-post-image,.post-thumbnail img,.site-content .post-thumbnail img{max-height: 1790px;}
	</style>
<style>
	    .site-content .post-thumbnail{background:none;}.site-content a.post-thumbnail:hover{background-color:transparent;}
		.site-content .post-thumbnail img{width:100%;}
	</style>
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<style type="text/css" id="twentyfourteen-header-css">
			.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
		</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="New Father John Misty video: God&#8217;s Favorite Customer" />
<meta property="og:url" content="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer" />
<meta property="og:description" content="Video: Father John Misty &#8211; &#8220;God&#8217;s Favorite Customer&#8221; Directed by Emma Tillman. From God&#8217;s Favorite Customer, out now on Sub Pop. Another bummer from Papa John Misery. …" />
<meta property="article:published_time" content="2018-07-05T13:35:45+00:00" />
<meta property="article:modified_time" content="2018-07-03T16:49:51+00:00" />
<meta property="og:site_name" content="Glorious Noise" />
<meta property="og:image" content="http://gloriousnoise.com/wp-content/uploads/2018/07/Father-John-Misty-Customer.jpg" />
<meta property="og:image:width" content="672" />
<meta property="og:image:height" content="372" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@gloriousnoise" />
<meta name="twitter:text:title" content="New Father John Misty video: God&#8217;s Favorite Customer" />
<meta name="twitter:image" content="http://gloriousnoise.com/wp-content/uploads/2018/07/Father-John-Misty-Customer.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@gloriousnoise" />

<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://gloriousnoise.com/?custom-css=4149d89355" />
</head>
<body class="post-template-default single single-post postid-17904 single-format-standard group-blog header-image singular">
<div id="page" class="hfeed site">
<header id="masthead" class="site-header" role="banner">
<div class="header-main">
<a href="http://gloriousnoise.com/" rel="home">
<img src="http://gloriousnoise.com/wp-content/uploads/2014/01/glono-logo-small.gif" width="174" height="48" alt="">
</a>
<h1 class="site-title"><a href="http://gloriousnoise.com/" rel="home">Glorious Noise</a></h1>
<div class="search-toggle">
<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
</div>
<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
<button class="menu-toggle">Primary Menu</button>
<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
<div class="menu-glono-menu-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-7292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7292"><a href="/">Home</a></li>
<li id="menu-item-7290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7290"><a href="/bb/">Message Boards</a></li>
<li id="menu-item-7291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7291"><a href="/label/">Record Label</a></li>
<li id="menu-item-7295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7295"><a href="http://gloriousnoise.com/contact">Contact Us</a></li>
</ul></div> </nav>
</div>
<div id="search-container" class="search-box-wrapper hide">
<div class="search-box">
<form role="search" method="get" class="search-form" action="http://gloriousnoise.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</header>
<div id="main" class="site-main">
<div id="primary" class="content-area">
<div id="content" class="site-content" role="main">
<article id="post-17904" class="post-17904 post type-post status-publish format-standard has-post-thumbnail hentry category-shorties tag-father-john-misty tag-sub-pop tag-videos">

<div id="jake-image-break"><br /><br /></div>

<div class="post-thumbnail">
<img width="672" height="372" src="http://gloriousnoise.com/wp-content/uploads/2018/07/Father-John-Misty-Customer.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://gloriousnoise.com/wp-content/uploads/2018/07/Father-John-Misty-Customer.jpg 672w, http://gloriousnoise.com/wp-content/uploads/2018/07/Father-John-Misty-Customer-300x166.jpg 300w, http://gloriousnoise.com/wp-content/uploads/2018/07/Father-John-Misty-Customer-560x310.jpg 560w" sizes="(max-width: 672px) 100vw, 672px" /> </div>
<header class="entry-header">
<div class="entry-meta">
<span class="cat-links"><a href="http://gloriousnoise.com/category/shorties" rel="category tag">Shorties</a></span>
</div>
<h1 class="entry-title">New Father John Misty video: God&#8217;s Favorite Customer</h1>
<div class="entry-meta">
<span class="entry-date"><a href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer" rel="bookmark"><time class="entry-date" datetime="2018-07-05T09:35:45+00:00">July 5, 2018</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="http://gloriousnoise.com/author/jake-brown" rel="author">Jake Brown</a></span></span> <span class="comments-link"><a href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer#respond">Leave a comment</a></span>
</div>
</header>
<div class="entry-content">
<p>Video: <a href="https://www.youtube.com/watch?v=sNG4g354P3w" rel="noopener" target="_blank">Father John Misty &#8211; &#8220;God&#8217;s Favorite Customer&#8221;</a></p>
<div class="lyte-wrapper" style="width:853px;max-width: 100%;margin:5px;">
<div class="lyMe" id="WYL_sNG4g354P3w" itemprop="video" itemscope itemtype="https://schema.org/VideoObject"><meta itemprop="thumbnailUrl" content="https://i.ytimg.com/vi/sNG4g354P3w/hqdefault.jpg" /><meta itemprop="embedURL" content="https://www.youtube.com/embed/sNG4g354P3w" /><meta itemprop="uploadDate" content="2018-06-19T14:00:07.000Z" /><meta itemprop="accessibilityFeature" content="captions" /></p>
<div id="lyte_sNG4g354P3w" data-src="https://i.ytimg.com/vi/sNG4g354P3w/hqdefault.jpg" class="pL">
<div class="tC">
<div class="tT" itemprop="name">Father John Misty &#8211; &quot;God&#039;s Favorite Customer&quot; [Official Music Video]</div>
</div>
<div class="play"></div>
<div class="ctrl">
<div class="Lctrl"></div>
<div class="Rctrl"></div>
</div>
</div>
<p><noscript><a href="http://youtu.be/sNG4g354P3w"><img src="http://i.ytimg.com/vi/sNG4g354P3w/0.jpg" alt="" width="853" height="460" /><br />Watch this video on YouTube</a></noscript><meta itemprop="description" content="Father John Misty&#039;s song &quot;God&#039;s Favorite Customer&quot; is off of his new album, God&#039;s Favorite Customer, out now on Sub Pop and Bella Union. Order God&#039;s Favorite Customer: https://fatherjohnmisty.store/ https://www.bellaunionstore.com (UK / EU) http://fatherjohnmisty.merchfan.com.au (AU / NZ) Listen to God&#039;s Favorite Customer: Spotify: http://bit.ly/fjmGFC-sp Apple: http://smarturl.it/gfcapplemusic Amazon: https://bit.ly/fjmGFCaz Soundcloud: http://bit.ly/fjmGFCsc Follow Father John Misty: Website - https://fatherjohnmisty.com/ Facebook - https://www.facebook.com/fatherjohnmi... Store - http://fatherjohnmisty.store Tour Dates - http://fatherjohnmisty.com/tour CREDITS Directed by Emma Tillman LYRICS: Another night on the straights All bug-eyed and babbling Out on the corner of 7th and A “I’m in the business of living” Yeah, that’s something I’d say All I need is a new friend I’m only five blocks away Speak to me Won’t you speak, sweet angel? Don’t you remember me? I was God’s favorite customer Beware the man who has everything Everything that he wants You can spot him from a mile away in his gold chain and only one pair of socks I’m out here testing the maxim That all good things have to stop The bar closes at five but the big man is just opening shop Speak to me (Won’t you speak to me?) Won’t you speak, sweet angel? Don’t you remember me? (Don’t you remember me?) I was God’s favorite customer But now I’m in trouble Speak to me (Oh, speak to me) Won’t you speak, sweet angel? I need some company (I need some company) I swear just one more night longer"></div>
</div>
<div class="lL" style="max-width:100%;width:853px;margin:5px;"></div>
<p><span class="via">Directed by Emma Tillman. From <em><a href="https://fatherjohnmisty.store/" rel="noopener" target="_blank">God&#8217;s Favorite Customer</a></em>, out now on Sub Pop.</span></p>
<p>Another bummer from Papa John Misery.</p>
<p><em>I&#8217;m out here testing the maxim<br />
That all good things have to stop<br />
The bar closes at 5<br />
But the big man is just opening shop</em></p>
<p>Once again, Tillman&#8217;s voice sounds great and the song is pretty but the lyrics are lamenting a period when he was &#8220;all bug-eyed and babbling&#8221; and separated from the woman he loves. Or, as it&#8217;s stated in the press release, &#8220;being caught between the vertigo of heartbreak and the manic throes of freedom.&#8221;</p>
<p>Of course, he&#8217;s reflecting on that experience with disgust. Which is not fun. Why does Tillman fear fun now? He might as well drop the &#8220;Misty&#8221; persona and resume recording as &#8220;J. Tillman&#8221; if he&#8217;s going to be this humorless and self-lacerating&#8230;</p>
<p>Maybe it&#8217;s time for a change. Maybe the &#8220;Misty&#8221; thing has peaked anyway. Look at his first-week sales history:</p>
<p>&bull; <em>Fear Fun</em>: 4,000 sold (<a href="https://www.billboard.com/articles/columns/chart-beat/6480019/modest-mouse-first-no-1-adult-alternative-songs" rel="noopener" target="_blank">May 2012</a>)<br />
&bull; <em>Honeybear</em>: 28,000 sold (<a href="https://www.billboard.com/articles/columns/chart-beat/6480019/modest-mouse-first-no-1-adult-alternative-songs" rel="noopener" target="_blank">February 2015</a>)<br />
&bull; <em>Pure Comedy</em>: 33,000 pure album sales (35,000 equivalent album units) (<a href="https://www.billboard.com/articles/columns/chart-beat/7767985/father-john-misty-pure-comedy-rock-album-charts-number-one" rel="noopener" target="_blank">April 2017</a>)<br />
&bull; <em>Customer</em>: 19,000 sold (22,000 equivalent album units) (<a href="https://www.billboard.com/articles/columns/chart-beat/8461271/greatest-showman-first-million-selling-album-2018-billboard-200-chart-moves" rel="noopener" target="_blank">June 2018</a>)</p>
<p>Maybe he&#8217;s overdue to gobble up some mushrooms, climb a tree, and contemplate the absurdity of his life again. <a href="http://magnetmagazine.com/2013/08/19/father-john-misty-misty-mountain-hop/" rel="noopener" target="_blank">It worked last time</a>. Stop being so serious. Time to <a href="https://www.youtube.com/watch?v=ga0ksTIagsg" rel="noopener" target="_blank">drown old Neil down on the beach</a> one more time.</p>
<p><strong>Father John Misty</strong>: <a href="https://fatherjohnmisty.com/" target="_blank">web</a>, <a href="https://www.amazon.com/gp/search?ie=UTF8&#038;keywords=Father John Misty&#038;tag=gloriousnoise-20&#038;index=music&#038;linkCode=ur2&#038;camp=1789&#038;creative=9325" target="_blank">amazon</a>, <a href="/redirect-apple.html?a=Father John Misty" target="_blank">apple</a>, <a href="https://open.spotify.com/search/artists/Father John Misty" target="_blank">spotify</a>, <a href="https://en.wikipedia.org/wiki/Special:Search?search=Father John Misty" target="_blank">wiki</a>.</p>
<script type="3b64d7081993e5362b9477a8-text/javascript">
jQuery(document).ready(function($) {
	$.post('http://gloriousnoise.com/wp-admin/admin-ajax.php', {action: 'wpt_view_count', id: '17904'});
});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-17904" class="share-twitter sd-button share-icon no-text" href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-17904" class="share-facebook sd-button share-icon no-text" href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://gloriousnoise.com/2018/new-father-john-misty-video-gods-favorite-customer?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<footer class="entry-meta"><span class="tag-links"><a href="http://gloriousnoise.com/tag/father-john-misty" rel="tag">Father John Misty</a><a href="http://gloriousnoise.com/tag/sub-pop" rel="tag">Sub Pop</a><a href="http://gloriousnoise.com/tag/videos" rel="tag">Videos</a></span></footer></article>
<nav class="navigation post-navigation" role="navigation">
<h1 class="screen-reader-text">Post navigation</h1>
<div class="nav-links">
<a href="http://gloriousnoise.com/2018/number-one-records-i-like-it" rel="prev"><span class="meta-nav">Previous Post</span>Number One Records: I Like It</a> </div>
</nav>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/new-father-john-misty-video-gods-favorite-customer#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&#038;postid=17904&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=0&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=6.1.1&#038;sig=adfa2474e5b9cf5df52f7af955bda999da3c61db#parent=http%3A%2F%2Fgloriousnoise.com%2F2018%2Fnew-father-john-misty-video-gods-favorite-customer" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
<!--[if !IE]><!-->
<script type="3b64d7081993e5362b9477a8-">
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div>
<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
<aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="height:0px;"></div></div></aside><aside id="r34otd-2" class="widget widget_r34otd"><h1 class="widget-title">On This Day: July 5</h1>
<ul class="widgets-list-layout no-grav">
<li style="margin-bottom: 0;">
<div style="">2001:&nbsp;
<a href="http://gloriousnoise.com/2001/idlewhile" rel="bookmark">Idlewhile</a>
<span class="via-grey"> by <a href="http://gloriousnoise.com/author/stephen-macaulay">Stephen Macaulay</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2001:&nbsp;
<a href="http://gloriousnoise.com/2001/queens_of_noise_the_runaways_s" rel="bookmark">QUEENS OF NOISE: THE RUNAWAYS SHOW BRITNEY WHO'S BOSS</a>
<span class="via-grey"> by <a href="http://gloriousnoise.com/author/johnny-loftus">Johnny Loftus</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2005:&nbsp;
<a href="http://gloriousnoise.com/2005/photos_of_madonna_at_live_8" rel="bookmark">Photos of Madonna at Live 8</a>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2007:&nbsp;
<a href="http://gloriousnoise.com/2007/stream_the_new_interpol_album" rel="bookmark">Stream the New Interpol Album</a>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2010:&nbsp;
<a href="http://gloriousnoise.com/2010/foals_total_life_forever" rel="bookmark">Foals - Total Life Forever</a>
<span class="via-grey"> by <a href="http://gloriousnoise.com/author/todd-totale">Todd Totale</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2012:&nbsp;
<a href="http://gloriousnoise.com/2012/accept-stalingrad" rel="bookmark">Accept - Stalingrad</a>
<span class="via-grey"> by <a href="http://gloriousnoise.com/author/todd-totale">Todd Totale</a></span>
</div>
</li>
<li style="margin-bottom: 0;">
<div style="">2017:&nbsp;
<a href="http://gloriousnoise.com/2017/the-model-500-and-the-physicality-of-music" rel="bookmark">The Model 500 and the Physicality of Music</a>
<span class="via-grey"> by <a href="http://gloriousnoise.com/author/stephen-macaulay">Stephen Macaulay</a></span>
</div>
</li>
<li><span class="via-grey"><a href="/this-day-bb.php" target="_blank">This day on the boards...</a></span></li>
</ul>
</aside> <aside id="wpt_widget-2" class="widget widget_wpt"> <div class="wpt_widget_content" id="wpt_widget-2_content" data-widget-number="2">
<ul class="wpt-tabs has-3-tabs">
<li class="tab_title"><a href="#" id="comments-tab">Comments</a></li>
<li class="tab_title"><a href="#" id="recent-tab">Recent</a></li>
<li class="tab_title"><a href="#" id="popular-tab">Popular</a></li>
</ul> 
<div class="clear"></div>
<div class="inside">
<div id="popular-tab-content" class="tab-content">
</div> 
<div id="recent-tab-content" class="tab-content">
</div> 
<div id="comments-tab-content" class="tab-content">
<ul>
</ul>
</div> 
<div class="clear"></div>
</div> 
<div class="clear"></div>
</div>
<script type="3b64d7081993e5362b9477a8-text/javascript">
				jQuery(function($) {
					$('#wpt_widget-2_content').data('args', {"allow_pagination":"1","post_num":"10","title_length":"15","comment_num":"5","show_thumb":null,"thumb_size":"small","show_date":"1","show_excerpt":null,"excerpt_length":"15","show_comment_num":null,"show_avatar":null,"show_love":null});
				});
			</script>
</aside> <aside id="twitter_timeline-2" class="widget widget_twitter_timeline"><h1 class="widget-title">Twitter</h1><a class="twitter-timeline" data-height="400" data-theme="light" data-link-color="#A25A1B" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter" href="https://twitter.com/gloriousnoise">My Tweets</a></aside><aside id="meta-3" class="widget widget_meta"><h1 class="widget-title">Meta</h1> <ul>
<li><a href="http://gloriousnoise.com/wp-login.php">Log in</a></li>
<li><a href="http://gloriousnoise.com/feed">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
<li><a href="http://gloriousnoise.com/comments/feed">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li> </ul>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><ul>
<li><a href="/contributors/">Contributors</a></li>
</ul>
</div></aside></div>
<div id="secondary">
<h2 class="site-description">Rock and roll can change your life.</h2>
<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
</div>
</div>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-info"><marquee>
<a href="https://wordpress.org/">Proudly powered by WordPress</a>
</marquee></div>
</footer>
</div>
<script type="3b64d7081993e5362b9477a8-text/javascript">var bU='http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyte/';var mOs=navigator.userAgent.match(/(iphone|ipad|ipod|android)/i);style = document.createElement('style');style.type = 'text/css';rules = document.createTextNode(".lyte-wrapper-audio div, .lyte-wrapper div {margin:0px; overflow:hidden;} .lyte,.lyMe{position:relative;padding-bottom:56.25%;height:0;overflow:hidden;background-color:#777;} .fourthree .lyMe, .fourthree .lyte {padding-bottom:75%;} .lidget{margin-bottom:5px;} .lidget .lyte, .widget .lyMe {padding-bottom:0!important;height:100%!important;} .lyte-wrapper-audio .lyte{height:38px!important;overflow:hidden;padding:0!important} .lyMe iframe, .lyte iframe,.lyte .pL{position:absolute !important;top:0;left:0;width:100%;height:100%!important;background:no-repeat scroll center #000;background-size:cover;cursor:pointer} .tC{left:0;position:absolute;top:0;width:100%} .tC{background-image:linear-gradient(to bottom,rgba(0,0,0,0.6),rgba(0,0,0,0))} .tT{color:#FFF;font-family:Roboto,sans-serif;font-size:16px;height:auto;text-align:left;padding:5px 10px 50px 10px} .play{background:no-repeat scroll 0 0 transparent;width:88px;height:63px;position:absolute;left:43%;left:calc(50% - 44px);left:-webkit-calc(50% - 44px);top:38%;top:calc(50% - 31px);top:-webkit-calc(50% - 31px);} .widget .play {top:30%;top:calc(45% - 31px);top:-webkit-calc(45% - 31px);transform:scale(0.6);-webkit-transform:scale(0.6);-ms-transform:scale(0.6);} .lyte:hover .play{background-position:0 -65px;} .lyte-audio .pL{max-height:38px!important} .lyte-audio iframe{height:438px!important} .ctrl{background:repeat scroll 0 -220px rgba(0,0,0,0.3);width:100%;height:40px;bottom:0px;left:0;position:absolute;} .lyte-wrapper .ctrl{display:none}.Lctrl{background:no-repeat scroll 0 -137px transparent;width:158px;height:40px;bottom:0;left:0;position:absolute} .Rctrl{background:no-repeat scroll -42px -179px transparent;width:117px;height:40px;bottom:0;right:0;position:absolute;padding-right:10px;}.lyte-audio .play{display:none}.lyte-audio .ctrl{background-color:rgba(0,0,0,1)}.hidden{display:none}" );if(style.styleSheet) { style.styleSheet.cssText = rules.nodeValue;} else {style.appendChild(rules);}document.getElementsByTagName('head')[0].appendChild(style);</script><script type="3b64d7081993e5362b9477a8-text/javascript" async src="http://gloriousnoise.com/wp-content/plugins/wp-youtube-lyte/lyte/lyte-min.js?wyl_version=1.7.0"></script>
<script type="3b64d7081993e5362b9477a8-text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/gloriousnoise.com\/2018\/new-father-john-misty-video-gods-favorite-customer":17904};
	</script>
<div id="sharing_email" style="display: none;">
<form action="/2018/new-father-john-misty-video-gods-favorite-customer" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value="" />
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value="" />
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value="" />
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img style="float: right; display: none" class="loading" src="http://gloriousnoise.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input type="submit" value="Send Email" class="sharing_send" />
<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<link rel='stylesheet' id='wpt_widget-css' href='http://gloriousnoise.com/wp-content/plugins/wp-tab-widget/css/wp-tab-widget.css?ver=4.9.6' type='text/css' media='all' />
<script type="3b64d7081993e5362b9477a8-text/javascript" src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201827'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-includes/js/comment-reply.min.js?ver=4.9.6'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/themes/twentyfourteen/js/functions.js?ver=20150315'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=6.1.1'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script async="async" type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.7'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript">
/* <![CDATA[ */
var wpt = {"ajax_url":"http:\/\/gloriousnoise.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/wp-tab-widget/js/wp-tab-widget.js?ver=4.9.6'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript">
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='http://gloriousnoise.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.1.1'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript">
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="3b64d7081993e5362b9477a8-text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=17904&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.1.1&sig=adfa2474e5b9cf5df52f7af955bda999da3c61db#parent=http%3A%2F%2Fgloriousnoise.com%2F2018%2Fnew-father-john-misty-video-gods-favorite-customer" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=23776706&postid=17904&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=0&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.1.1&sig=adfa2474e5b9cf5df52f7af955bda999da3c61db#parent=http%3A%2F%2Fgloriousnoise.com%2F2018%2Fnew-father-john-misty-video-gods-favorite-customer";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script type="3b64d7081993e5362b9477a8-text/javascript" src='https://stats.wp.com/e-201827.js' async='async' defer='defer'></script>
<script type="3b64d7081993e5362b9477a8-text/javascript">
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1.1',blog:'23776706',post:'17904',tz:'-4',srv:'gloriousnoise.com'} ]);
	_stq.push([ 'clickTrackerInit', '23776706', '17904' ]);
</script>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/4f936b58/cloudflare-static/rocket-loader.min.js" data-cf-nonce="3b64d7081993e5362b9477a8-" defer=""></script></body>
</html>
